Puzzled - SSL or no SSL

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.6
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.8.2
Theme version 21.09
Package updates All installed packages are up to date
Box name Education

I have just logged in to this box (first time for days).

Logged on as usual with https://domain.com:10000
and was met with the
Screenshot 2023-10-18 084318

now this is rubbish! As the website is working fine with SSL
and checking in Virtual Server Summary
Screenshot 2023-10-18 083843

All other domains on the box also seem to be normal. ie with valid SSL

On the Not Secure connection, have you check the certificates expiry date, not via virtualmin but in the browser.

Yes and just rechecked - says the “certificate is valid” and the dates are correct

Weird, only other thing I can think is the Common Name doesn’t match.

Weird - yes - hence the post. The Common Name Issued To (CN) is the name of the domain. The Common Name Issued By (CN) is “R3” Org (O) is “Lets Encrypt” which I think is normal.

I think I’m going to reapply for a new SSL.

Got a shiny new Cert from LE with no problem - and is showing as valid still
but still not for Webmin/Virtualmin and I have logged out and back in again.

I have also just noticed that the browser Title (Chrome) is showing a different domain name than the one I’m logged in as (also a domain on this box)
Yet under Virtualmin it is showing the correct domain and the correct domain summary location.

It is as if it is logged in as a different domain (but I’m logged in as root (not the client owner of the domain)

I would check with two different browsers Brave and Firefox, both with the cache purged. The causes can also be from other sources, not strictly from the certificate.

1 Like

If you go to example.com - Server Configuration ⇾ SSL Certificate page do you see the button to Copy SSL certificate to Services … ? If you do, click it. It will copy SSL certificate from the virtual server to be used with Webmin and other services.

When done, close current Webmin tab and re-open it. Do you have it working now?

No I see Remove SSL Certificate from Services

No change made but I have tried logging out of Webmin/Virtualmin, closing the browser page and opening a new browser and logging in again (same browser - Chrome)
Still no change.

I will try Firefox

That worked - so Chrome is US -even the title was back to just the module.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.