Proftpd install issues

I was having some issues with proftpd and one suggestion was to reinstall it. I uninstalled it and immediately tried to reinstall it and now no matter how I approach it (virtualmin UI,SSH), I get a 404 error that seems to be causing it be able to find a downloadable repo. Can someone help me resolve?


Key Error:
https://GPL:GPL@software.virtualmin.com/gpl/amazon/latest/i386/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

failure: repodata/repomd.xml from virtualmin: [Errno 256] No more mirrors to try.

Trying other mirror.

Amazon Linux has not been supported by us for many years. How’d you install?

For Virtuamin packages you may be able to switch to the CentOS repo for the CentOS version that is closest to your version of Amazon Linux (but figuring out what version that is is tricky, as their packaging/versioning policy is insane, or at least, it was last I looked into it).

But, for ProFTPd, you probably just want to disable the Virtualmin repos (there is no amazon repo, anymore) and try again. The OS repos provided by Amazon probably have ProFTPd and this is just failing because there is no Virtualmin repos but it’s trying to fetch from them.

Anyway: Don’t use Amazon Linux with Virtualmin. We don’t test there and don’t try to keep up with it. They’re really bad at making a Linux distribution and CentOS runs fine on AWS.

1 Like

Thanks so much! That allowed me to get ProFTPd installed again. It sounds like I need to put migrating off of Amazon Linux on my TODO list for the near future. (I had installed it via a package VirtualMin provided a long time ago).

I am back to where I started however before I uninstalled ProFTPd. ProFTP won’t start. It looks like an update must have broke my configuration in some capacity. I’ve done a bit of debugging, but I stuck. Any ideas? Here is the output of a couple of commands.

Running: proftpd --configtest
Output:
Checking syntax of configuration file

  • notice: unable to bind to Unix domain socket at ‘/var/run/proftpd/test.sock’: Permission denied
  • notice: unable to listen to local socket: Operation not permitted
  • ROOT PRIVS: unable to seteuid(): Operation not permitted
  • ROOT PRIVS: unable to setegid(): Operation not permitted
  • RELINQUISH PRIVS: unable to seteuid(PR_ROOT_UID): Operation not permitted
  • RELINQUISH PRIVS: unable to setegid(session.gid): Operation not permitted
  • RELINQUISH PRIVS: unable to seteuid(session.uid): Operation not permitted
  • Fatal: SystemLog: unable to redirect logging to ‘/var/log/proftpd/proftpd.log’: Permission denied on line 90 of ‘/etc/proftpd.conf’

Running: /usr/sbin/proftpd
Output:

  • warning: handling possibly truncated configuration data at line 189 of ‘/etc/proftpd.conf’
  • warning: unable to determine IP address of ‘ip-XX-XXX-XXX-XX’
  • error: no valid servers configured
  • Fatal: error processing configuration file ‘/etc/proftpd.conf’

None of those are config errors. That’s a bunch of permission/privilege problems.

My guess would be that you’ve re-enabled SELinux since Virtualmin was installed. If you’re going to use SELinux, you’ll need to change a bunch of booleans and maybe add some custom rules (and, ProFTPd may not even be included in the default SELinux configs for Amazon Linux…I wouldn’t know as I haven’t looked at it in several years). Disabling it is the simplest.

Er, actually, you also have a config file problem. I don’t have a simple solution for you, since this is a very old install (new installs have a tool for re-doing Virtualmin config changes that happen on installation). There’s probably a default config file in /etc/proftpd.conf.rpmnew.

It’ll need some tweaks to work the way Virtualmin sets it up…your install is so old that it won’t have virtualmin-config, so you’ll need to manually make those tweaks. Here’s the plugin with the changes we make: https://github.com/virtualmin/Virtualmin-Config/blob/master/lib/Virtualmin/Config/Plugin/ProFTPd.pm

Hopefully you can read a little Perl, though the important bit is the config file snippet at the end that goes into /etc/proftpd.conf.d/virtualmin.conf (at line #103).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.