ProFTPd authentication method


I am trying to log in over SFTP to my server, but it looks, that server want authenticate with public key, not with password.
proftpd[19704]: pam_listfile(proftpd:auth): Refused user root for service proftpd
proftpd[19704]: pam_unix(proftpd:auth): authentication failure;

WinSCP returns : Disconnected: No supported authentication methods available (server sent: public key).
How can I change FTP authentication method to password please?

hi, what os is this?

Debian 8.7

ah that is simple but allowing the root to login via password is not very much advised… security concerns you should deploy ssh keys for your system so you would be allowed to log in without any passwords or at least fail2ban protection… anyway if you still need it here is what you need to do:

As root, edit the sshd_config file in /etc/ssh/sshd_config : nano /etc/ssh/sshd_config

Change following: PermitRootLogin without-password to PermitRootLogin yes and then of course restart sshd server with /etc/init.d/ssh restart to apply changes… then you will be able to log into ssh as root with password auth.

you can now use filezilla as ssh or sftp to manage your files as root. also you can log into your server as root via command like : ssh

I do not need to login as root over SFTP. I cannot login as common FTP user created with virtualmin into SFTP (same message)

cau lionwebsk

I think you got little confusion here, let me get it for you straight, sftp = ssh and ftp is not sftp. SSH File Transfer Protocol (also Secure File Transfer Protocol, or SFTP) - source. Ftp can be secured only by ssl and it calls FTPS which is totally different thing. I do not use ftp as it is not secure enough and if I have secure option like sftp then I always use it. In end of the day this means you can only log into sftp (ssh) as linux user which is something totally different as common ftp user. Try to log into FTP with your ftp user and not into sftp and it would work.

try this, its fix that for me:

unborn thanks, I tried FTP too, but unseuccessfull.
Kvark thank you, on FTP I have connection refused, so I followed that tutorial and now my FTP works.