ProFTP again

Hi guys,

i’ve rebuilt one server with current webmin / virtualmin with a Ubuntu 14.04. But i still have the problelm, that ProFTPd dies almost daily.

I can have a check on that process and reboot it, but i am wondering, why this is happening in the first place.

Any idea?


And it’s been happening for over a year on Ubuntu 14, too. My Virtualmin server’s FTP worked properly for nearly a year until it started shutting down. I can’t pin down the exact date since FTP logs only go back a few weeks.

I see it almost daily, after a server reboot it is working for several hrs, when i check the next day, usually it is gone …

If you have developers, which are using that ftp, you get a hard time…

I thought i would get rid of it with a new server setup from scratch, but no avail.


What shows up in /var/log/syslog and the various logs in /var/log/proftpd when that occurs? Also, what is the output of “free -m”?


total used free shared buffers cached Mem: 15958 15468 489 33 187 13794 -/+ buffers/cache: 1487 14471 Swap: 8183 213 7970

proftpd logs:

ProFTPD killed (signal 15)
ProFTPD 1.3.5rc3 standalone mode SHUTDOWN
ProFTPD 1.3.5rc3 (devel) (built Fri Dec 20 2013 18:05:41 UTC) standalone mode STARTUP


I see the same pattern. The log shows ProFTPD killed with signal 15, then ProFTPD says it’s shutting down, then it either starts up again shortly, or the log shows it starting up hours or days later when I restart it manually. Among the various times of day it occurs, there are 3 periods it tends to happen more often.

Shutdowns between 4 AM and noon are almost certainly automatic events I did not initiate. Shutdowns which are in early afternoon to late at night, are likely just me manually rebooting to install updates. ProFTPD always starts up properly when the server is rebooted.

Shutdowns between 6:25 - 7:05 (usually close to 6:30) always result in FTP failing to restart on it’s own. This could be related to the 6:25 batch of scripts run daily. But note that ProFTPD does NOT shutdown daily. If the time of day it shuts down is NOT around 6:30, it starts back up on it’s own in 2-25 minutes.

6:25 DAILY cronjob: /etc/cron.daily/passwd /etc/cron.daily/aptitude /etc/cron.daily/upstart /etc/cron.daily/update-notifier-common /etc/cron.daily/apport /etc/cron.daily/mlocate /etc/cron.daily/dpkg /etc/cron.daily/bsdmainutils /etc/cron.daily/man-db /etc/cron.daily/apt-show-versions /etc/cron.daily/spamassassin /etc/cron.daily/apache2 /etc/cron.daily/quota /etc/cron.daily/apt /etc/cron.daily/popularity-contest /etc/cron.daily/webalizer /etc/cron.daily/logrotate

These ~6:30 AM shutdowns occur 6-10 days apart. This is usually a Sunday or Monday. Every Sunday at 6:47 these jobs are scheduled to run:

/etc/cron.weekly/update-notifier-common /etc/cron.weekly/apt-xapian-index /etc/cron.weekly/fstrim /etc/cron.weekly/man-db

I tried running the 6:47 cronjob manually, which did not produce output (in web console) and it did not result in ProFTPD shutting down (tailing /var/log/proftpd/*log)

It isn’t a case of ProFTPD failing when both cronjobs are running, since it usually (not always) fails after the 6:25 job starts, but before the 6:47 cronjob starts. I doubt it’s a case of running out of ram or drive space since the server has 2GB ram and over 2GB drive space (it’s running as a virtual machine on a 4-core system with 8GB ram).

Perhaps a Virtualmin architect knows something that this could be related to? I’m eager to help fix this. Just tell me what to check for.


i can’t see a pattern. I have several backupjobs running in the course of morning, but sometimes proftpd runs for more than a day or less, depending when my developer is working on our webpage and claiming to restart it :wink: The Logfiles include always the entry seen above, sometimes i do a complete restart, after fumbling around with serverbased restart, after installing Redmine or OTRS or Etherpad or something else, but it might be, that i restarted (and shutdown) the proftpd service before anyhting else could stop it. Since i am still setting up the server, and having to reboot several times, it might be, that the proftpd-killing-ghost wasn’t triggered yet, because as long as i am doing a restart once a day, it continues to work. On the other server, where it dies regularly, i have given up, and moved our webpage, which we are devleoping on this new rebuilt server, hoping, that this wouldn’t show up at all, but what it apparently did.

Thanks and best

Any update here? I checked as of today, and ProFTPd died again.

Somone please?

I will try to find what I used, but it’s an Ubuntu issue, there is a fix in the config I just can’t remember right now.

edit: ok that was quick, this worked for me: