Processing Conflict: php-mysql-5.4.24-1.el6.remi.x86_64 conflicts php-mysqlnd

I have the FATAL error doing an install on an install on CentOS Linux 6.5 (Kernel and CPU: Linux 2.6.32-220.2.1.el6.x86_64 on x86_64) with the last 15 lines of the error below. I’m using webmin too.

I’ve tried a yum downgrade on mysql which cleaned out the dbs - luckily a test system, but still no luck. I’ve also removed mysql & the server too - nada.

Any help will be useful as I need to run pear scripts on a Magento that require a php version less than 5.3 and I can see it can be done with VirtualMin.

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
—> Package perl-IO-Compress-Base.x86_64 0:2.021-136.el6 will be installed
—> Package perl-IO-Compress-Zlib.x86_64 0:2.021-136.el6 will be installed
—> Package perl-TimeDate.noarch 1:1.16-11.1.el6 will be installed
–> Running transaction check
—> Package db4-cxx.x86_64 0:4.7.25-18.el6_4 will be installed
—> Package glibc-headers.x86_64 0:2.12-1.132.el6 will be installed
–> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.132.el6.x86_64
–> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.132.el6.x86_64
—> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed
–> Running transaction check
—> Package kernel-headers.x86_64 0:2.6.32-431.3.1.el6 will be installed
–> Processing Conflict: php-mysql-5.4.24-1.el6.remi.x86_64 conflicts php-mysqlnd
–> Finished Dependency Resolution
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log


What distro/version is it that you’re using there?

It looks like you have third party repositories enabled, which may cause some additional trouble… but CentOS 6 comes with PHP 5.3, there isn’t a simple way of adding PHP 5.2 to a CentOS 6 system (PHP 5.2 is no longer supported by the PHP devs).

CentOS 5 does come with PHP 5.2 though, and they backport security fixes into PHP 5.2.


Yo andreychek,

It’s a build of a VM that I’ve just recently bought, but I think it’s a remi distro? Err, may have that wrong…

I think I’ll get the hosting company to recover a back up from a few days ago as I’m getting no where.

Magento is a horror to upgrade from and I’m thinking I should just bite the bullet and see about installing the latest version and load the db.

Deep in the mud here, but thanks for replying.



Well, I suspect you’re using CentOS.

Remi is a third party repository that can be enabled for CentOS, though we don’t recommend doing so, as that can cause some problems.

If you’re able to restore your system to the way it was prior to updating to packages from within the Remi repo, that may resolve some of the issues you’re seeing.



I’ve had the server rebuilt from scratch to clear it all out and start fresh.

The install went in cleanly with no errors - phew. Just waiting for the DNS to catch up for the domain I use and I should be good.

Nice. Thanks for your help!