Problems with ssl

SYSTEM INFORMATION
OS type and version ubuntu 20.04
Virtualmin version 7.7 pro

can anyone help me im trying to setup letsencypt but i keep getting this error

The server/domain needs a real world IP, not a 192.168.xxx.xxx IP.

1 Like

expanding on this, maybe just change your hosts file to reflect your real world IP using webmin->Network Configuration->Host Addresses

1 Like

could you guide me on how to change that or tell me what i need to do please

Just curious, if you use change IP, does the public IP show in the dropdown?

where do i need to look for it on the screenshot on mine

That why I use screensot, the menu on the left shows where to find, and the yellow is the dropdown.

no its not showing any other ip addresses just the one im using

Have you rechecked configuration just to see if it find the public IP (not very hopeful) Else you will need to add the IP in Webmin -->Network Configuration. I haven’t done that for many years (like at least 5).

click on the current interface (ip), see what options you have

Add virtual interface, this is “maybe” where you can add the public IP

this what showing in my host inter face

You could try changing the private to public ip on last line.

ok i will try that firist and see what happens


this is what is showing up in my ssl

worked by the looks

so i dont need to do anything to change anything

Screenshot_6

ok, please see if you can now change ip on the virtualserver

cert not from lets encrypt

shared address please change, use the letsencrpt if you can. don’t buy certificate unless you need to.