Problems with new Mail Autoconfig

The Mail Autoconfig is a welcome addition as it eases setup by Thunderbirds users and the like.
However, it is not very usable in my case, for the following reasons:

  • The username is wrong. I have “domain.tld_user” style usernames, however the username in the XML is “domain.tld_” without the user part.
  • It specifies SSL for the incoming server, however no SSL for the outgoing, although it is supported
  • It also forces the hostname to be “mail.domain.tld”, but for certificate reasons I would prefer it to be the hostname of the machine running Virtualmin in my case

So all in all, there is probably a bug with the user names, and I think the rest should be made configurable by the Virtualmin admin: ports, ssl enable/disable, hostname.

Unless of course I missed something in which case please tell me what I can do to get it working for me :slight_smile:


I don’t have the first problem on any of my two different servers with different user schemes (one is user-domain-tld and the other is user.domain.tld), but i DO have the other two:

  • I want my users to use TLS on outgoing emails.
  • I would also like to force them to use certain mail server.

Hmmm any chance some of this feedback will make it into a next Virtualmin version? :slight_smile:

In the next Virtualmin release, you will have full control over the XML that is returned by the auto-configuration feature … so if you want to force a specific encryption type or mail server name, that will be possible.

wicked, thanks! :slight_smile:

Any updates on this? Is there any information or documentation on this, now that it’s included in the last virtualmin update (and doesn’t appear to work).

Any intentions for a fix?