problem with WHMCS moudle using FCGId (run as virtual server owner)

i am running on Xen VPS WHMCS with virtualmin

when i try to create new virtual server using WHMCS i am getting internal server error 500, but when i look at virtualmin CP i see the virtual server was created.
in my error log i see this message:

[Thu Apr 26 19:40:54 2012] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Thu Apr 26 19:40:54 2012] [error] [client 79.183.205.29] Premature end of script headers: clientshosting.php, referer: https://mydomain.com/admin/clientshosting.php?userid=2&hostingid=18
[Thu Apr 26 19:40:55 2012] [emerg] mod_fcgid: server is restarted, 27765 must exit

this is only happen when i am using FCGId (run as virtual server owner)
if i use Apache mod_php (run as Apache’s user) this is working without any problem

i would like to work with FCGId since it consuming a lot less memory

does anyone have any how to solve this problem?

yes run CGI for the whmcs domain
FCGI triggers a reload of apache during the process thus you’re getting an error

Thanks for your reply but this didn’t work but still did the request as the same the differences now i get this error log message:

[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] Security Alert! The PHP CGI cannot be accessed directly., referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] , referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29]

This PHP CGI binary was compiled with force-cgi-redirect enabled. This, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] means that a page will only be served up if the REDIRECT_STATUS CGI variable is, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] set, e.g. via an Apache Action directive.

, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29]

For more information as to why this behaviour exists, see the manual page for CGI security.

, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29]

For more information about changing this behaviour or re-enabling this webserver, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] consult the installation file that came with this distribution, or visit , referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] the manual page.

, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange
[Thu Apr 26 20:59:44 2012] [error] [client 79.183.205.29] Premature end of script headers: php5.cgi, referer: https://mydomain.com/admin/clientshosting.php?userid=2&id=18&act=pwchange

any more ideas?

Try editing your $HOME/etc/php.ini file, and set “cgi.fix_pathinfo=0”.

Once you do that, log out and back into WHMCS, and see if that resolves it.

-Eric

Good one Eric, I forgot about that change.
I knew I was missing something as I had the same issues with whmcs on my box.

early this year I moved the whmcs installation to another box which is also an option if you want to run Apache in FCGI mode.

Thank you both for the help
Eric your suggestion worked out and every is working now.

Great, I’m glad to hear that helped!

Ronald, is that a common issue with WHMCS whenever it runs on PHP 5.3?

Do you think the install script should be setting that php variable automatically?

-Eric

Eric, yes it is a common issue and yes for whmcs install script.

my php ini is
cgi.fix_pathinfo = On
my php.ini has
cgi.fix_pathinfo 1
PHP Version 5.3.3