Problem with the the email setup Pstfix/dovecot


I manually installed Virtualmin with Postfix.

I have trouble running Dovecot. and I create email accounts and they’re created but when I send an email I et bounces from the mail system telling that it doesn’t exist.

Can I tell Virtualmin to use Exim instead?
I think I messed up the configuration of Dovecot and I really need to use my smtp server because Hotmail is rejecting my PHPmailer mail.

Best regards,


Whenever performing a Virtualmin install – we’d always recommend using the automated installation… it makes it a lot simpler to get things working.

One thing you could do though is to go into Server Configuration -> Re-Check Config to see if any problems are detected.

However, we don’t recommend Exim – it’s not supported very well. Postfix, the default mail server on Virtualmin system, is the best supported, and more people are able to offer assistance with it :slight_smile:


Ok, I wont give up!!

I ran Check configuration and I got

Mail server Postfix is installed and configured.

So, no problems are detected. However I can’t start Dovecot and I dont really know what to enter in the

Data source for users, homes and IDs
and Password authentication source

and I get " Failed to start Dovecot :
Starting IMAP/POP3 mail server: dovecot."
Whenever I try to start it.

Thanks a lot. I’m not familiar with Dovecot at all I ran a Qmail server for 5 years and I thought Postfix was going to be easy but apparently I started with the wrong foot.

Thanks for helping!


Can anyone post the normal postfix configuration file?

My error log reads:

2012-02-10 13:32:06 dovecot: Info: Dovecot v1.2.15 starting up (core dumps disabled)
2012-02-10 13:32:06 auth(default): Fatal: Support not compiled in for passdb driver ‘vpopmail’
2012-02-10 13:32:06 dovecot: Fatal: Auth process died too early - shutting down

You’re having a Dovecot configuration problem, rather than a Postfix one.

Are you trying to use vpopmail there? That appears to be your problem, there’s something about your Dovecot config that’s not working, and according to the error you posted, that may be related to vpopmail.


Hi Eric,
Could you please post your dovecot configuration so I can compare the files?

I tried to use all the auth methods, none of them work. Which is the default in VM install?
I know I have sasauth running but I get error in auth everytime.

best regards,

Well, the dovecot config is different on different distributions and versions.

What output do you get if you run the command “dovecot -n”?




root@ithaki:/var/log/mysql# dovecot -n # 1.2.15: /etc/dovecot/dovecot.conf # OS: Linux 2.6.32-5-amd64 x86_64 Debian 6.0.4 log_timestamp: %Y-%m-%d %H:%M:%S protocols: imap pop3 imaps pop3s ssl_listen: * login_dir: /var/run/dovecot/login login_executable(default): /usr/lib/dovecot/imap-login login_executable(imap): /usr/lib/dovecot/imap-login login_executable(pop3): /usr/lib/dovecot/pop3-login mail_privileged_group: mail mbox_write_locks: fcntl dotlock mail_executable(default): /usr/lib/dovecot/imap mail_executable(imap): /usr/lib/dovecot/imap mail_executable(pop3): /usr/lib/dovecot/pop3 mail_plugin_dir(default): /usr/lib/dovecot/modules/imap mail_plugin_dir(imap): /usr/lib/dovecot/modules/imap mail_plugin_dir(pop3): /usr/lib/dovecot/modules/pop3 auth default: passdb: driver: pam userdb: driver: passwd root@ithaki:/var/log/mysql#