Problem with subdomains

I have successfully installed Webmin with Virtualmin extension, I have also successfully added new virtual server (domain), but there is the problem… some ISP does not work correctly with subdomains of this domain…

For example:
ping - does not work (is not responding and does not show webpage)
ping - works fine (responds, and shows webpage).

I have already tried to reinstall OS, webmin and virtualmin, but still the same.

NS records for domain are configured correctly.

Where can be a problem?

Hmm, it’s possible that one or more of your nameservers isn’t behaving properly.

Try going to:

Enter your domain, and it’ll do some tests to make sure things are running properly.

Thank you, I have configured wrong host name of server…

How can I change host name of server (including hostnames inside Virtualmin DNS, etc…)?

Thank you for reply.

under the webmin section you need to go to the networking module-Network Configuration, then go to Hostname and DNS Client to change the hostname of the server.

or ssh into the server and type: hostname something.domain.tld


Thank you, hostname was changed, but subdomains still does not work…

Here is page from intoDNS: - it looks, that all is configured correctly

Subdomains works just with some internet providers.
Mostly ping to subdomain (e.g. ping, returns: Host was not found.

Any other idea, how to make subdomains working correctly?

If you SSH onto your server, and type “host”, does it return an IP address?


yes, it shows correct IP: has address mail is handled by 5

Yeah, I’m not sure why that’s not working.

It sounds like a DNS issue of some sort, but I’m not sure what.

If you put the “” domain into the site, does it check out okay? I think it was another domain you had tried in there.

Beyond that – I guess we’d need to see what the specific domain name is that’s not working to be able to help diagnose the problem you’re seeing.

e2ads has a ptr record containing
Now I don’t know your set up but at least has many dns problems