Problem with postfix


we are trying to deploy some installations of virtualmin GPL on machine without postfix installed.

But when try to "rechek" virtualmin configuration we get this log:

Checking Configuration
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

  Apache is installed.

  Webalizer is installed.

  MySQL is installed and running.

  Logrotate is installed.

  Using network interface eth0 for virtual IPs.

  Default IP address for virtual servers is x.x.x.x

  Failed to query Postfix config command to get the current value of parameter virtual_alias_maps:
  <-  Return to previous page 

This happens also if virtual-server/config has mail=0.
Can u pls help?

Specs of machine running virtualmin:
OS Gentoo
Virtualmin 3.49
Webmin 1.350

Make sure that mail is turned off in the system settings, as Postfix is the default and will look for it.

Make sure you uncheck mail, spam and virus checking in the features and plugins

But mail, antivirus and antispam are disabled in virtualmin config :frowning:

Is postfix still running though? I know nothing about Gentoo so VM might still be lulled into looking for a place to setup virtmapping if an MTA is still running.

The process worked fine on CentOS, THough setting it back up is a pain because of the ClamAV problem.

Hi, postfix is’nt running, because it isn’t installed.
By default, gentoo come with a tiny sendmail replacement, called ssmtp.

This could be the problem?

Having another MTA installed shouldn’t cause any trouble. I suspect there’s still something mail-related enabled in your configuration…but I can’t guess what.

I’ll ask Jamie to chime in on this thread. In the meantime, you might double check to be sure you have disabled all mail-related features in the Module Configuration.

Hi Joe,

Double check done, all mail related configuration for virtualmin are set on 0.

I’ll try to deploy a test machine without ssmtp (that come by default on gentoo) and I’ll post the result.

Thank u guys :slight_smile: