Problem with manual entries in Spamassassin

I have a carefully curated list of domains I don’t want to receive mail from, entered in the “Allowed and Denied” section of Spamassassin. For years, this worked perfectly. However, I recently had to reinstall the base OS and Virtualmin, after which I transferred my list of domains over to the Allowed and Denied section of Spamassassin. Since doing that, it’s just stopped working and even though the domains are properly listed, I’m still getting unsolicited mail from them. ‘Ordinary’ spam is still intercepted, but my manual entries don’t work anymore.

I’ve tried everything I can think of to get it working. Spam filtering is confirmed as active on each user and each virtual server. I even did a yum remove on spamassassin and reinstalled it again via Webmin, but it just won’t work. My guess it’s probably some kind of permissions issue but I don’t know where to look. Do you have any tips for me? I hope someone can help because this unwanted mail is driving me around the twist.

Ssh in and edit the config files - what is wrong with you?

OK smart arse, what should the permissions be and on which files. What’s wrong with you?