Problem with Mailman

I have a new installation of Virtualmin Pro on a new CentOS5 server. I have created an ip based virtual server with Mailman lists enabled. I have created a mailing list on that virtual server. Mail sent to the list is not forwarded to subscribers.

I have seen “FS#3205 - Mailman doesn’t send mail and other problems” where you say this problem can be solved by starting the Mailman process. Here’s what happens when I try to do that:

[root@server1 ~]# service mailman status mailman is stopped [root@server1 ~]# service mailman start Starting mailman: Site list is missing: mailman [FAILED]

I see in FS#3205 that someone else reported the same thing, and Joe responded:

Yeah, you need to have that 'mailman' list. Oddly, Virtualmin is supposed to create it as part of the install process .. was this a recent Virtualmin install?

Joe’s comment does not say what to do if Virtualmin did not do what he says it is supposed to do. My install did not do whatever it was supposed to do in that regard either. Yes, it is a very recent install.

So what do I have to do to get Mailman working? And if Virtualmin did not do what it was supposed to do in this respect, should I be concerned that it is broken in other ways as well?

otis

The following bug is tracking this issue :

http://www.virtualmin.com/bugs/index.php?do=details&task_id=3314

OK -
As instructed, I ran

/usr/lib/mailman/bin/newlist mailman

from the command line, copied the aliases into /etc/aliases, ran newaliases and started the mailman service. The test list I created now seems to work.

I would like to configure this mailman list. When I go to Webmin | Servers | Virtualmin Mailman Mailing Lists I can see the mailman list in the list in the right hand frame. When I click the "Manage" button I get to the Mailman management interface. But when I try to submit changes, I get a Mailman screen that says "No such list virtualmin-mailman"

So how do I configure the "mailman" list?