Problem uploading big file

Hi, I set up proftpd in my server and I’m trying through filezilla to upload a backup of blog to my new server. The problem is the file is gigantic (in this case 3gb), and after upload a certain ammount of gbs it fails and it refuses to continue the upload. How can I upload such a big to my server? How do I configure virtualmin to allow the upload?


Ps: No, it is not a problem of space, I have a 500gb hd, and I set up a quota to unlimited.

Virtualmin doesn’t impose any limitations like that, but your ProFTPd configuration might (MaxStoreFileSize is the directive for that, probably). But, Virtualmin wouldn’t have added it, and I don’t think it’s set by default on any distros, but I might be wrong about that.

I usually use rsync for very large files. It handles resuming very very well, and if the big file changes and needs to be re-uploaded, rsync can just send the differences.

What error exactly do you get in your client? And, check the proftpd log for more information (you haven’t told us your distro/version, but on CentOS that’s in /var/log/proftpd), which may tell you why it’s failing.

Hi, I solved that problem, apparently the server doesn’t resume your download if you had uploaded before you changed the 1gb default quota.

But I have another problem, now that I reuploaded the file, I can’t extract it.

I run Debian Wheezy (you asked), and I want to unzip my file through virtualmin but the option doesn’t appear to me, both zip and unzip are installed and I restarted apache2. Can you help me?


Edit: I installed filemin and cannot find an uncompress option.

Edit: I installed filemin and cannot find an uncompress option.

I don’t really know anything about Filemin at this point; the File Manager we ship is a fork of Filemin (I’d like it if we could converge back into the same thing, but it’s not happened yet). Extract appears in the right-click menu when you hover over a file in the File Manager we ship with Virtualmin/Webmin. AFAIK Filemin still has compatibility issues with Authentic theme.

Restarting apache2 does not restart Webmin. Webmin/Virtualmin does not run under Apache, it has its own application server. You can restart Webmin by restarting the webmin service.

I tried to remove the filemin file manager now the only file manager that appears to me is the java one, is there a way to repair this?


hi, just use ssh aka sftp, there are no limits at all… ftp is clear text data transfer which is bad it self enough plus limits and it eats resources. secured ftp aka ftps is brutally slow and limits are still there not to mention instability,. I aint use ftp for years. fille zilla supports ssh, just on your connection select ssh or if its not there select sftp (not ftps). and you should be able to upload even bigger files. Also my suggestion is to advice to avoid ftp for anything if you have that option. on server you dont have to mess with anything. ssh is automatically there, just use domain user name and password, dont have to be even root…