Problem setting Virtualmin

The webroot is ‘/var/www/index.html’ and not ‘/home/user/public_html’

Edit ‘/etc/apache2/sites-available/default’, ‘/etc/apache2/sites-available/default-ssl’ and ‘/etc/apache2/sites-available/’

I haven’t Internet, the forwarders isn’t working


Network > IP:; Mask:; Route:; DNS:

/etc/hostname > user

/etc/resolv.conf > nameserver

/etc/hosts > localhost; user;

/etc/bind/named.conf.options > forwarders {;; };


If I delete the line ‘forwarders’ from ‘named.conf.options’, and I add the first IP to DNS network’s configuration all work, but I need the forwarders…

What’s wrong? What can I do?

PD: Sorry for my bad Spanglish

man, you should use nameservers that point to a IP address.
If you use that must point to an IP address: = IP (
You can check that in

Thanks! Where have I to configure that? In ‘/etc/hosts’? ?

The Ubuntu installed should have asked you what your IP address and that of your default gateway and nameserver is – except it used DHCP to discover that. In any case, the configuration for the local resolver is in /etc/resolv.conf. Make sure you have an IP address in there that points to your nameserver.

The Virtualmin installer will add as nameserver, since it installs BIND which the local system also uses as resolver. Check if that is done and correct.

  1. In ‘/etc/resolv.conf’ I have ‘nameserver’. Is this ok?

  2. I saw that the webroot isn’t ‘/home/user/public_html’ (now is ‘/var/www/index.html’). Why?

  3. I just edit the first post with more information…

Did you use the Virtualmin installer script on a fresh and “blank” Ubuntu? You should not install any other packages besides SSH when setting up Ubuntu, and let the installer do the rest.

Thanks for your answers!

I just install Ubuntu (erasing the entire disk) and later I install Virtualmin with the SH script. What I saw is that Virtualmin have updates from Ubuntu before installing Virtualmin. Something it’s wrong…

I deleted the line (added by me) ‘forwarders {;; };’ from ‘/etc/bind/named.conf.options’ and added the first in DNS network’s configuration > DNS:, And it works, but I need the forwarders to add more IPs…

What can I do? For more information I just edit the first post…

PD: Sorry again for my Spanglish

I could solve the problem. Thank you very much for your responses!