Problem port 20000 for webmin

Sorry for my English …
I’m trying to install VirtualMin, using the sh script, but I get an error when installing usermin on my server because I’m already using port 20000 with another process.
I wonder if there is the possibility of change within the script to use the another port or do I install VirtualMin “by hand”. thanks a lot.

Howdy,

Could you temporarily disable the service you’re running on port 20000?

It only needs to be disabled long enough for the install.sh script to install… after it’s installed, you can turn Usermin off, and then have it run on another port.

When using the automated installer, it’s not possible to have Usermin use an alternate port. But if you could temporarily disable your other service on that port, Virtualmin and Usermin should install correctly, and then you could disable Usermin and re-enable your existing service.

-Eric

I thought so … is that the port 20000 is used for a VPN, for which I worked hard and is used by many people. I’m afraid of not being able to restart the service (it works very well for a year). I’m no expert, so I have this fear … Thanks for the reply. Would you have any other tips?

Howdy,

Well, remember that the install.sh script is meant to be run on a new system, with a fresh installation of your Linux distribution. So there could indeed be issues if there are already things running on it.

That said – you could always edit the install.sh, and remove all the references to “usermin”.

That would prevent Usermin from being installed.

Usermin is a webmail client, and you could simply use a different webmail client, such as RoundCube.

-Eric

ok, thanks now I feel. Thank you again.