Problem installing wordpress script due to lack of quota

OS type and version DEBIAN 10
Virtualmin version 7.0-4

Hello, I try to install the wordpress 5.9.3 script in my “subserver” and it shows me the error "Failed to install script: This script requires 128 MiB of free disk quota, but only 0 bytes is available
"I checked in system/disk quota that I have allocated 170Gb to the main domain. Can you please give me a clue? Thanks


Thanks for reporting it.

A sub-server always shares a system Unix user and thus quotas with the parent’s domain main user. Although, this is always best to create top-level server even for sub domains.

@Jamie, however, the problem here, and which I could reproduce is that when sub-server is created and there is not enough quota left on the parent domain, it creates a sub-server but later always reports back incorrect quota (initial quota that happened to exist upon sub-server creation), even though you later increase quota for the parent server and it has enough of the space available.

Additionally, if you create a new user in a sub-server, it has an option to set quotas, which however not getting saved, and the quotas are always set as Unlimited and the user marked in red:

(you can always see the OS and the version on the URL of the screenshot)

The work-around would be is to convert sub-server into a parent server using - Server Configuration ⇾ Move Virtual Server page.

This problem has just appeared with me exactly the way it’s described here only problem is I have tried your work a round and it doesn’t seem to fix it for me, is there any other alternatives to fix this or is it just about waiting for an update?


I Found a another workaround just create another plan and and change it on your account and all should work, you can always change it back afterwards.

I’ve checked in a fix that should resolve this issue : Always check quota in top-level domain… · virtualmin/virtualmin-gpl@96ea4fe · GitHub

Thanks for the help. Can you tell me how to use the patch? In which folder should this file be placed? Thank you

I found the folder where the file is hidden in my case, it is found in: /usr/share/webmin/virtual-server. I therefore replaced my file with the one updated just above, then I had to restart the machine, which was mandatory because the modification would not work otherwise. thank you

It would be enough to restart Webmin only by running /etc/webmin/restart command.

Thanks, Jamie. It fixed the issue.

I’m trying to install Wordpress on main domain, not a sub-domain and still get that quota thing. Actually I get the current quota in negative. That is, I have used around 85 MB of user quota, and i get the following error message when trying to install Wordpress: “Failed to install script : This script requires 128 MiB of free disk quota, but only -42.5 MiB is available” while I have a disk quota of 100 GiB assigned to the server. I just don’t get it. Looks like the server cant read the instructions in config file. How can I manually change the file with the quota thing?

Also, that fix in Github doesn’t work for me. Since it checks for the quota, it just reads the quota as wrong. Interestingly, i tried to install phpmyadmin and roundcube, and they went through smothly. So, I figure it has something in the wordpress script that doesn’t seem to work since the virtualmin update-mind you, I already had a previous version of wordpress installed on this virtual server, but took it out for testing purposes… I tried to upgrade wordpress on the same machine in another virtual server and it was ok, no problems. So I’m guessing I have to delete this server and re-create it to test the whole thing again.

I’ll appreciate if you have better alternatives. I’m all for learning new things. Thanks in advance.

Also, that fix in Github doesn’t work for me.

The fix really works. After editing a file you would need to restart Webmin manually by running /etc/webmin/restart command.

How can I manually change the file with the quota thing?

By using a text editor. You can find the file by running find /usr -name command.

Sorry to say the GitHub fix doesn’t work for me either.

Tried /etc/webmin/restart and also a hard reboot of the server.

Clearly something changed recently, as I was able to install Wordpress on other domains on this server 2 days ago, but the script was for WP 5.8.x and now it is for WP 5.9.3 and has a new method of WP CLI installation. Is there an easy way to revert to the working version of the WP install script?

What exactly doesn’t work for you? What error do you see when trying to install it?

Failed to install script : This script requires 128 MiB of free disk quota, but only -1003.7 MiB is available

Quotas are set to unlimited. There is 60gb of free space on this disk. Debian 10, Virtualmin 7.0-4

I inserted the three recommended lines of code in the proper place in: /usr/share/webmin/virtual-server/

Restarted Webmin. Did not work. Rebooted server. Did not work. Same error message every time.

I’m sorry. You’re right, it still didn’t work with unlimited quotas.

Here is the patch —

Thank you. That worked with unlimited quota.

I’m sorry, it was the unlimited quota setup that messed things around. The fix with unlimited quota did the trick.

I usually edit codes directly in the file while I’m at the contol panel (be that cPanel or Virtualmin), don’t have the time to go the long way (I just download the first version of the file prior to editing it).

Hats-off to you Ilia, you were very helpful.

1 Like

Hello @Ilia,

How do I go about applying this patch?


1 Like

If you’re still running Virtualmin 7.0.0-5 (or -4) you can update your local copy of of file with this particular version.

You can find where file is on your system by running:

find /usr -name

… and restarting Webmin afterwards by running /etc/webmin/restart command.