problem installing php-xml


I’d like to install Drupal 7 which requires, among other things, php-xml. so here’s what happens:

[root@davestevens etc]# yum install php-xml
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons:
 * base:
 * extras:
 * updates:
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
--> Finished Dependency Resolution
php-xml-5.1.6-27.el5_5.3.x86_64 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

I’ve tried the suggestions to no avail.



Hmm, so what output do you get if you run this command:

rpm -qa | grep php-common

[root@davestevens default]# rpm -qa | grep php-common


Okay, so it looks like you have a custom PHP version installed, which isn’t part of CentOS. Where ever you pulled your custom PHP version from, that’s where you’d also have to obtain the PHP-XML package :slight_smile:


I dunno,

I just got 3.84 Pro upgrade and tried installing Drupal 7 with the VMPro installler on a different server and am getting:

" Your PHP installation is too old. Drupal requires at least PHP 5.2.4. See the system requirements page for more information."

[dave@bulkley ~]$ rpm -qa | grep php-common

Yeah, 5.1.6 is the default PHP version available on CentOS.

And for that, I’d typically recommend using Virtualmin’s bleed repository in order to get PHP 5.2.x:

I think I have to park this for now, Eric, it seems to be a bigger issue. RHEL 6 has in fact got 5.3.6 in the standard repo but CentOS is challenged right now getting CentOS 6 out the door, hence the need for bleeding edge. I’m just evaluating D7 right now so can wait a bit.

Thanks for your help.


hai bro…try this
sudo yum –enablerepo=webtatic install php53-xml