problem in email-server

Hello, I have already installed virtualmin, But I think some problem be there about email service to establish and configuration well. I was wondering if it can be solved here (Postfix/Dovecot).
The problem is publishing pop3 and imap (that seems doesn’t automaticly allow in firewalld of centos as soon as virtualmin installation is completed).
I also configure smtp inbound 25 access from outside well. but it seems altough I have opened it in firewallD and connection but also it doesn’t show open from outside.
even other service like pop3s or imaps (that automaticly opened) have the same status (show closed/filter).
However SMTP 25 Shows “open” well. I also do the same for usermin in 20000. it works fine too. I want to ask does there anything else (like other port) that should opened in firewall too? I think this is abnormal. I check all of configuration, but honestly nothing found.
At the second, also MX, A and SPF record is existed in a public DNS record however sending mail seems not be able to deliver successful to outside, even there show successfully sent but no email put in user inbox. I test it by sending to example gmail account.
Let me now about if there is something that I must do it to using mail server successfully.
Also if any docs already there for its configuration and required port that should be open to use it.
Thanks in advance,

Im not understanding your english grammar well…are you saying all email ports are closed even though you have opened them? Are you saying nothing is being delivered or recieved too?

If so…

What type of network restrictions does your hosting provider have in place for email?

Some providers permanently restrict all or some email ports (25,465,587), perhaps this may be your problem?

For example google cloud dont allow any standard email ports on their vps instances (with one exception that is of little help here). So to use email on networks with similar restrictions to google cloud, you have to configure postfix to use an outside mail relay host such as sendgrid. Ie setup postfix to use a non standard port to connect with sendgrid, and sendgrid relay on port 25, 465,or 587 for you so email can be delivered.

If smtp is working then my above thought is probably partially or completely wrong and its your mx records are incomplete or postfix configuration is incorrect.

Dear adamjedgar, Thank you for reply and apologize about English grammar.
you say: “are you saying all email ports are closed even though you have opened them? Are you saying nothing is being delivered or recieved too?”
The answer is “Yes” for “both” of them.
The 25,110,995,587 ports is already opened in the server. there is no problem for access with local ip at all. I have also opened it that can be accessed from the outside too.
The thing is strange for me is SMTP on 25 works from outside but it is not the same about pop3 port! So I think it has low probability about port restriction. I have also host my server by own. As another test, I successfully access usermin from the outside too after publishing.
The thing that I have found is it seems virtualmin install pop3s and 995 (not 110 by default). however many email system want to work in pop3 and 110.
I’m also afraid that these protocol works using SSL/TLS and it caused to show port block or message delivery be failed.
However I have also tried with port 110 and open it from outside. obviously I think since i cant reach this port through outside I can not expect about other steps in mail delivery process. I also can send email and “no error” message show after sending. But I am almost sure about required MX and A record for DNS. however maybe SPF, PTR, DKIMM cause my email doesn’t delivered correctly using gmail. I know maybe GMAIL Delivery test does not consider good for test. because it check the sender so hard to validate it. how nothing found in even spam or inbox. Maybe its better to clean install it again. maybe there occurred strange issue.
Also thanks for your help.