Problem creating lists with mailman module

SYSTEM INFORMATION
OS type and version Debian 12
Virtualmin version 7.8.2 Pro

Problem with mailman3 module, version 6.10 does not let me use it, the module indicates that /var/lib/mailman3/ does not exist, when it does exist, the previous versions available give me the same failure, the latest version 6.11 does not give me that failure but without the previously created lists do not appear, and in the domain drop-down section does not appear any, so it is impossible for me to create lists through this module.

@Jamie you worked on the mailman3 module just recently, do you know what the issue could be?

Does /var/lib/mailman3 or /var/lib/mailman exist on your system? Also, which package version of Mailman do you have installed?

Yes, /var/lib/mailman3 exists

GNU Mailman 3.3.8 (Tom Sawyer)

ns:~# -la /var/lib/mailman3/

total 44

drwxr-xr-x 11 list list 4096 oct 2 23:05 .

drwxr-xr-x 80 root root 4096 oct 3 21:36 …

drwxr-xr-x 3 list list 4096 oct 2 23:29 archives

drwxr-xr-x 2 list list 4096 oct 2 23:05 cache

drwxr-xr-x 2 list list 4096 oct 2 23:29 data

drwxr-xr-x 3 list list 4096 oct 2 23:29 lists

drwxr-xr-x 2 list list 4096 oct 4 11:23 locks

drwxr-xr-x 2 list list 4096 oct 2 23:05 messages

drwxr-xr-x 14 list list 4096 oct 2 23:05 queue

drwxr-xr-x 2 list list 4096 oct 2 23:05 templates

drwxr-x— 4 www-data www-data 4096 oct 2 18:22 web

Possibly it is a permissions issue, because if I run mailman from another user than root it gives me permissions problems in several directories

/etc/mailman3$ mailman version

Traceback (most recent call last):

File “/usr/bin/mailman”, line 33, in .

sys.exit(load_entry_point('mailman==3.3.8', 'console_scripts', 'mailman')())

         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 1130, in call

return self.main(*args, **kwargs)

       ^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 1054, in main

with self.make_context(prog_name, args, **extra) as ctx:

     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 920, in make_context

self.parse_args(ctx, args)

File “/usr/lib/python3/dist-packages/click/core.py”, line 1613, in parse_args

rest = super().parse_args(ctx, args)

       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 1378, in parse_args

value, args = param.handle_parse_result(ctx, opts, args)

              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 2360, in handle_parse_result

value = self.process_value(ctx, value)

        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/click/core.py”, line 2322, in process_value

value = self.callback(ctx, self, value)

        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

File “/usr/lib/python3/dist-packages/mailman/bin/mailman.py”, line 95, in initialize_config

initialize(value)

File “/usr/lib/python3/dist-packages/mailman/core/initialize.py”, line 228, in initialize

initialize_1(config_path)

File “/usr/lib/python3/dist-packages/mailman/core/initialize.py”, line 122, in initialize_1

mailman.config.config.load(config_path)

File “/usr/lib/python3/dist-packages/mailman/config/config.py”, line 145, in load

self.push(filename, user_config.read())

File “/usr/lib/python3/dist-packages/mailman/config/config.py”, line 151, in push

self._post_process()

File “/usr/lib/python3/dist-packages/mailman/config/config.py”, line 163, in _post_process

self.ensure_directories_exist()

File “/usr/lib/python3/dist-packages/mailman/config/config.py”, line 266, in ensure_directories_exist

with Lock(lock_file):

File “/usr/lib/python3/dist-packages/flufl/lock/_lockfile.py”, line 439, in enter.

self.lock()

File “/usr/lib/python3/dist-packages/flufl/lock/_lockfile.py”, line 307, in lock

self._write()

File “/usr/lib/python3/dist-packages/flufl/lock/_lockfile.py”, line 467, in _write

with open(self._claimfile, 'w') as fp:

     ^^^^^^^^^^^^^^^^^^^^^^^^^^

PermissionError: [Errno 13] Permission denied: ‘/var/lib/mailman3/mailman/locks/mailman-cfg.lck|ns.almogavers.net|3757610|368368736496798783’

It is also in that the mailman’s virtualmin library file looks for

our $rmlist_cmd = “$mailman_dir/bin/mailman remove”;

our $list_lists_cmd = “$mailman_dir/bin/mailman lists”;

our $changepw_cmd = “$mailman_dir/bin/change_pw”;

our $config_cmd = “$mailman_dir/bin/config_list”;

our $withlist_cmd = “$mailman_dir/bin/withlist”;

our $lists_dir = “$mailman_var/lists”;

our $archives_dir = “$mailman_var/archives”;

our $domains_map = “$mailman_var/data/postfix_domains”;

our $lmtp_map = “$mailman_var/data/postfix_lmtp”;

our $maillist_map = “relay_domains”;

our $maillist_file = “$postfix_dir/maillists”;

our $transport_map = “transport_maps”;

our $cgi_dir = “$mailman_dir/cgi-bin”;

our $icons_dir = “$mailman_dir/icons”;

but all these commands are inside the mailman file, they do not exist by themselves.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.