Problem after updating mysql database from 5.4 to 5.7

Hi I was trying to restore my wordpress website (which I backed up with the duplicator plugin), but I had to update php and mysql, everything worked just fine, I was trying to create a database and a user to this backup and I got this error:

Failed to save user : SQL insert into user (host, user, Select_priv, Insert_priv, Update_priv, Delete_priv, Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv, File_priv, Grant_priv, References_priv, Index_priv, Alter_priv, Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv, Execute_priv, Repl_slave_priv, Repl_client_priv, Create_view_priv, Show_view_priv, Create_routine_priv, Alter_routine_priv, Create_user_priv, Event_priv, Trigger_priv, Create_tablespace_priv, ssl_type, ssl_cipher, x509_issuer, x509_subject, authentication_string) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) failed : Duplicate entry ‘%-zephw’ for key ‘PRIMARY’

Anytime I try any kind of option, I run into this problem.

Could you help me out?


Where are you seeing this error, specifically?

As far as I know, MySQL 5.7 is pretty well-supported in Virtualmin at this point, though there were a ton of problems for the first couple of months after people started using it.

I was creating a mysql user for my database in webmin/virtualmin, I want to create a database to my wordpress that I can use as my main database for my backup, while creating the user I got this kind of error. But when I try to create an user I got some kind of error like this one for example:

Failed to save user : SQL set password for 'zephw'@'localhost' = password('[edited]') failed : Column count of mysql.user is wrong. Expected 45, found 42. Created with MySQL 50557, now running 50719. Please use mysql_upgrade to fix this error.

I edited the password on this line, the rest is the original line. I’m just trying to create an user for my database so that I can use in my wordpress. (Probably I shouldn’t choose localhost as my host but the database.

What version of Webmin do you have? I thought that was one of the issues that was already fixed.

Oh, wait. You haven’t actually upgraded your database! That’s not a Webmin issue; you have to follow the full upgrade instructions from the MySQL folks.

Do you have a link please?