PostgreSQL not running - database list not found

Webmin > Servers > PostgreSQL Database Server

Error message is “PostgreSQL is not running on your system - database list could not be retrieved.”

When I manually try to start I receive this error:

Failed to start service :

  • Starting PostgreSQL 9.1 database server
  • The PostgreSQL server failed to start. Please check the log output:
    2013-09-07 18:14:14 EEST LOG: database system was interrupted; last known up at 2013-09-07 18:03:50 EEST
    2013-09-07 18:14:14 EEST LOG: database system was not properly shut down; automatic recovery in progress
    2013-09-07 18:14:14 EEST LOG: record with zero length at 0/1704E80
    2013-09-07 18:14:14 EEST LOG: redo is not required
    2013-09-07 18:14:14 EEST FATAL: could not access status of transaction 1
    2013-09-07 18:14:14 EEST DETAIL: Could not read from file “pg_multixact/offsets/0000” at offset 0: Success.
    2013-09-07 18:14:14 EEST LOG: startup process (PID 26223) exited with exit code 1
    2013-09-07 18:14:14 EEST LOG: aborting startup due to startup process failure

Any ideeas? I already google on this and can’t figure how to resolve.


Are you using Postgres on your server? Or would you be okay disabling it?

And which distro/version are you using?


Operating system Ubuntu Linux 12.04.1
Kernel and CPU Linux 3.2.0-53-generic on x86_64

I don’t use Postgres especially but when I restarted the server SpamAssasin failed due postgress start failure.

In Webmin module - PostgreSQL is not running on your system - database list could not be retrieved.

Seams that the primary postgres database is corrupted and I’m not sure how to proceed.


If you’re not using Postgresql, the easiest solution would be uninstalling its packages, after disabling the Postgresql feature in Virtualmin. Why bother with an error in something you don’t use anyway. :slight_smile:

I’m surprised though that SpamAssassin should fail to start due to Postgres… SA doesn’t use PG at all, as far as I know.

Regarding SpamAssasin I was surprised too :slight_smile:

Your suggestion. I already tried to disable postgres as Virtualmin feature but I have 1 virtual servers using the feature PostgreSQL database …

Now, when I tried to remove the feature from the specific server I have the error bellow:

In domain ****.com
Deleting PostgreSQL login …
… PostgreSQL database failed! : DBI connect failed : could not connect to server: No such file or directory Is the server running locally and accepting connections on Unix domain socket “/var/run/postgresql/.s.PGSQL.5432”? at /usr/share/webmin/ line 1376, line 1.

That I supose because the Postgres Server is not running. There is a manual method to delete the feature from virtualserver?

Alright, that’s a vicious circle then indeed… :slight_smile:

I guess what you could try is purging the postgres package, then reinstalling it to have it in an empty slate status, then try to remove the feature from your virtual server again. And hope that won’t fail because it can’t find the to-be-deleted user. :wink: In that case, Jamie has to intervene here.


Yeah, that is unfortunate! From Virtualmin’s point of view, it wants to remove the things it setup in Postgres in order to disable the service… but it doesn’t understand that may not be what we want in this case :slight_smile:

It is indeed possible to manually disable that feature.

To do that, log into your server as root on the command line, and cd into the directory ‘/etc/webmin/virtual-server/domains’.

Each file in that directory represents a Virtual Server (it’s the domain ID).

There, run this command:

grep postgres *

Do any of the “postgres=” lines indicate one of those Virtual Servers having postgres enabled? That typically means you’d see something like “postgres=1”.

If so, try changing that to 0, and then restart Webmin with this:

/etc/init.d/webmin restart

Hi, thank you for information, that was really useful.
I cleaned the virtual-server/domains and I disabled Postgres from features.
After that I removed postgres from system completely.

apt-get --purge remove postgresql*

The following step was to reinstall postgress and dependencies from Webmin/Postgresql server module.
All process run smooth and now postgres server is up and running.

For final tests I run Re-Check Configuration from Virtualmin. … your system is ready for use by Virtualmin.

Thank you again :wink: