Postgres (1.9) settings in webmin for Debian?

I’ve created a Debian 6 VM via virtualbox on my local machine - before taking the plunge on a production server - and do like what I’ve seen so far. Erasing the old postgres and replacing it with 9.1 was quite elegantly handled - I just erased the old package and used backports to get the latest one :slight_smile:

However, Virtualmin/webmin is not picking it up. I think I have put all the correct paths in there, but still it says: ‘PostgreSQL is not running on your system - database list could not be retrieved.’

Postgres 9.1 is running on the system, just not being picked up by webmin. Here are my settings, do they look ok?

Any ideas what I might be doing wrong?


Well, it’s tough to say, as most distributions aren’t using Postgres 9.1… but my suspicion is that it’s somehow related to the path to the PID file.

I see from your screenshot that you’ve updated that, but you may want to triple-check that the “Path to postmaster PID file” option points to a file that exists while Posgres is running.


Hi Eric, thanks for the reply.

That’s the only file I get with a find:

$ find / -name

If I just enter the file name I get permission denied:

bash: /var/lib/postgresql/9.1/main/ Permission denied

Or on opening I get these contents:

5433001 983041

All of the other paths I found via find too. Any other ideas on what it might be? Thanks.

Hey Eric, is there a log file where virtualmin logs at what point it fails? I could look at that for clues.