Postfix - Virtualmin Install Script not Working Correctly on Centos 6 x64 Anymore

I can reproduce this problem. If you install Virtualmin on a Centos 6 x64 VPS, it won’t pass configuration. You get the following error in Postfix:

postfix: fatal: parameter inet_interfaces: no local interface found for ::1

This is a problem related to IPv6, but if you fix it by modifying the Postfix conf file:

inet_protocols = ipv4

You now get a new error related to procmail that results from the location of procmail not being in the Postfix config. However, it you edit it to the correct location, Virtualmin still complains and won’t pass as it says spam filtering is not set up.

It looks like the portion of the install script that relates to Postfix don’t run correctly on this version of Linux anymore?


What is the Postfix “inet_interfaces” parameter set to before you changed it?

Also, what’s the procmail error you’re receiving, and what did you tweak there?

I’m trying to determine whether the issue is a tweak we need to make in order to better support your VPS environment, or whether there’s a larger problem that’s occurring.

However, so far we haven’t been able to reproduce a problem installing Virtualmin onto CentOS 6.



Postfix cfg has inet_protocols = all. When I change it ti ipv4, I next get this error:

Automatic BCCing of outgoing email cannot be enabled unless a BCC map is defined in the Postfix Mailserver module, or manually in the Postfix configuration file. Otherwise it must be turned off on the module configuration page

When I turn off auto bcc off, I get this error:

The Procmail program needed for spam filtering does not appear to be installed on your system, or has not yet been set up properly in Webmin’s Procmail Mail Filter module. If your system does not use spam filtering, it should be disabled in Virtualmin’s module configuration page.

At this point I tried googling this error and found that the mailbox_command should be set to /usr/bin/procmail in Postfix’s Here is what I found:

#mailbox_command = /some/where/procmail
#mailbox_command = /some/where/procmail -a “$EXTENSION”

I uncommented the first command and changed it to /usr/bin/procmail. Again Virtualmin would not start with another error.

At this point this problem was starting to look like the proverbial Russian nesting doll, something is seriously wrong here, so I gave up and posted.

In case this is helpful, Virtualmin installed without error when I installed the 32 bit version on this VPS. The VPS has 512MB of memory and 64mb of vswap

Thanks for all the info! I’ll look into all that and do some testing today.

Note that the mailbox_command should actually be set to the following:

mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME

Thank you for the help. I used the information that you posted, and hit the recheck button. This time the error was on that I am familar with the qrunner error related to mailman. I fixed this as I always do by removing mailman from the services on the features and plugins page.

Now Virtualmin will pass configuration, but I noticed an update required. Perhaps this is the source of the problem, the update was procmail. Perhaps something in the script is not compatible with the version of procmail in Centos 6 x64?