postfix + user@domain

(in gpl)

while using postfix, i can’t select user@domain as format for new users:

"The Module Config option Format for usernames that include domain is set to username@domain, which is only supported by Sendmail."

But this is actually not true, as i have a perfectly good working setup - if i rename users from user-domain.tld to user@domain.tld and update the virtal map.

I’m using a simple postfix install w/ sasl->pam authentication.

IMHO, this error(?!?) should not exist or at least be a warning but let it work anyway.

thanks.

Hey Joao,

Actually, it is true. Postfix will not deliver to a user named user@domain.tld under any circumstances, as of several years ago (and Wietse has stated he will never re-add support for it). You have to use rather complex mappings to get it all to work and we’re working on handling those mappings, though I still don’t think we’ve got it exactly right. We’ve been through quite a lot of agony over this seemingly little issue already (almost enough to convince us to switch to Sendmail as the default MTA in Virtualmin Professional), and it’s still not quite resolved. You can see the following bugs for the full details of the issue and why it is currently the way it is in Virtualmin GPL:

http://www.virtualmin.com/bug-tracker/bug?bug_number=198
http://www.virtualmin.com/bug-tracker/bug?bug_number=356

The first one details how to fix the immediate problems, the second details a problem that hasn’t quite been addressed (and there are a few others, I’m pretty sure).

When the code merge happens with the next major GPL release, the changes we’ve made in Professional will find their way into GPL. I’ll never really recommend using @ in usernames with Postfix, however, as it has a lot of negative side effects which we’re still trying to accomodate–and if you use any other software, like webmail packages, with the system you might run into new problems.

Just in case you don’t find your way through the bug discussion to this gem from Wietse regarding Postfix and support for @ in usernames here’s a snippet of the relevant discussion on postfix-users:

>] As of Postfix version 19991231 you cannot have usernames with @ (or any >] routing operator such as %, or !). > > bummer ... is that likely to ever change?

Nope. Too many mailers treat @ as a routing character, and the fact
that Postfix didn’t was causing ugly mail relay vulnerabilities
with mail forwarded by Postfix to non-Postfix systems.

> if not that means i can’t use
> postfix which is a real shame. other then change all my users names to
> something without an in it and do the translation another way, can anyone
> think of any other options?

Don’t allow usernames with characters that have special meaning to
mail handling systems.

In short, not much to be done other than follow Wietse’s orders, or do things with complex mappings. As soon as we get all of the mappings figured out, it will be possible (but, again, never recommended).

Hi Joao,

The way we handle it now, is user_domain_ext whe just replace the @ and . with underscores, it’s works well. Maybe this will work for you??

Hey Mikel,

Where are you seeing an option named “user_domain_ext”? Postfix doesn’t have such an option (at least not one that I can find in the postconf(5) manpage), and even Google doesn’t know what it is. Could you elaborate on this?