Postfix smtp auth config

I am using Postfix for my mailserver.

I want to enable smtp authorization to force the user to login to send mail. so when they set up thier outlook profile they must enable the "my server requires authorization" to send email.

how do i set up smtp authorization for postfix?

from my /etc/postfix/main.cf

[code:1]
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
[/code:1]

anyone… have a clue how to enable this?

This should have been enabled by default during installation, if you used install.sh. No changes should be needed, unless you’re using @ in usernames (like user@domain.tld). If that’s the case, you’ll need to modify the saslauthd configuration as documented in this FAQ:

http://www.virtualmin.com/faq/cat/virtualmin/68/#faq30

In short, add "-r" to the "FLAGS=" or "OPTIONS=" field (depending on OS and version) and restart saslauthd.

If this isn’t the case, then we’ll need to see the maillog or mail.log entries when you attempt to send to figure out why it is failing.