PostFix send e-mails to .Com's but not .Edu, .Net

Hello All,

I’m having an issues with Postfix which it will send e-mail out to gmail.com and anything that has a .com, but it will not send e-mails to .net, .edu and so on. I’m using a client (Thunderbird) to send the e-mail, but when I login to Webmail and send it that way, I don’t get any error back.

Here is my config file postconf -n

[code:1]

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
mydestination = $myhostname, localhost.$mydomain, $mydomain
readme_directory = no
recipient_delimiter = +
sender_bcc_maps = hash:/etc/postfix/bcc
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
virtual_alias_maps = hash:/etc/postfix/virtual

[/code:1]

And here is the Error I get sending a e-mail to a .Edu from a Client.

[code:1]

Feb 11 18:09:50 MyServerName postfix/smtpd[20261]: NOQUEUE: reject: RCPT from domain.com[...]: 554 5.7.1 <lthomas@latech.edu>: Relay access denied; from=<my@email.com> to=<thetest@latech.edu> proto=ESMTP helo=<[192.168.1.101]>

[/code:1]

Note: I have change the IP to ... and where it’s coming from. Also the postfix -n looks small from other configs I seen. I’m thinking it could be the config but no clue or the smtpd_recipient_restrictions section.

P.S. This is my first e-mail server so yeah - n00b here.

Thanks,

Chris

I got it working…

It was a problem with saslauthd not talking to postfix.

Here is the link I followed from if anyone has problems like this!

http://jonsview.com/2008/07/14/setting-up-email-services-on-ubuntu-hardy-using-postfix-and-courier