Postfix problem - cannot connect for outgoing mail

Hello,

I am having issues getting a migrated cpanel domain to send mail. (centos 6.2 / 3.89.gpl)
I have searched but cant find anything that works… There are errors below… Any ideas how to fix this?

Also if i recheck virtualmin config i get this:

No sender canonical map file for outgoing addresses was found in your Postfix configuration. You should either add the appropriate map to Postfix, or disable this feature in Virtualmin’s module config page.

I also noticed that postfix keeps going down, must restart…

Thanks a lot!

My mail log:

Jan 8 02:00:20 mail01 postfix/postfix-script[16011]: starting the Postfix mail system
Jan 8 02:00:20 mail01 postfix/master[16012]: fatal: open lock file /var/lib/postfix/master.lock: unable to set exclusive lock: Resource temporarily unavailable
Jan 8 02:05:02 mail01 postfix/sendmail[16455]: warning: the Postfix sendmail command has set-uid root file permissions
Jan 8 02:05:02 mail01 postfix/sendmail[16455]: warning: or the command is run from a set-uid root process
Jan 8 02:05:02 mail01 postfix/sendmail[16455]: warning: the Postfix sendmail command must be installed without set-uid root file permissions
Jan 8 02:05:02 mail01 postfix/pickup[14191]: D41FF61341: uid=501 from=
Jan 8 02:05:02 mail01 postfix/cleanup[16463]: D41FF61341: message-id=20120108070502.D41FF61341@targetmyad.net
Jan 8 02:05:02 mail01 dkim-filter[15080]: D41FF61341: no signature data
Jan 8 02:05:02 mail01 postfix/qmgr[30197]: D41FF61341: from=root@targetmyad.net, size=3774, nrcpt=1 (queue active)
Jan 8 02:05:03 mail01 spamd[22348]: spamd: connection from localhost [127.0.0.1] at port 57501
Jan 8 02:05:03 mail01 spamd[22348]: spamd: setuid to target succeeded
Jan 8 02:05:03 mail01 spamd[22348]: spamd: processing message 20120108070502.D41FF61341@targetmyad.net for target:501
Jan 8 02:05:03 mail01 spamd[22348]: spamd: clean message (0.0/5.0) for target:501 in 0.3 seconds, 3816 bytes.
Jan 8 02:05:03 mail01 spamd[22348]: spamd: result: . 0 - NO_RELAYS,TVD_SPACE_RATIO scantime=0.3,size=3816,user=target,uid=501,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rport=57501,mid=20120108070502.D41FF61341@targetmyad.net,autolearn=ham
Jan 8 02:05:03 mail01 postfix/local[16466]: D41FF61341: to=target@targetmyad.net, orig_to=, relay=local, delay=0.61, delays=0.11/0.01/0/0.49, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME)
Jan 8 02:05:03 mail01 postfix/qmgr[30197]: D41FF61341: removed
Jan 8 02:05:03 mail01 spamd[22325]: prefork: child states: II

Anyone?
All i can find that seems relevant now is this log:

postfix/master[20766]: fatal: open lock file /var/lib/postfix/master.lock: unable to set exclusive lock: Resource temporarily unavailable

anyone know what this means?
Thanks

Solved

Thanks andreychek for your help!

Looks like this issue was submitted in the request tracker here:

https://www.virtualmin.com/node/20710

Access denied to https://www.virtualmin.com/node/20710, so would be nice to outlay the solution publicly.

Hi, that is perhaps because ticket was resolved and then closed… after while (year or more time) it gets to be auto-deleted. - You do realize that this post is older then 2 years right? Generally speaking for myself, I believe pro support tickets (if they share them between users and helpdesk which would be bad decision) should be only visible for clients who purchase pro support. I would rather keep pro tickets private for each user due to things shared with helpdesk like ssh access, passwords and other sensitive information submitted by (pro support purchased) clients to helpdesk. So I think its correct that we do not have access.

Hi! I i cannot send a mail out and get this in mail.log

Oct 23 15:16:30 ns1 postfix/smtps/smtpd[52443]: connect from unknown[192.10.0.1]
Oct 23 15:16:31 ns1 postfix/smtps/smtpd[52443]: warning: TLS library problem: error:14094419:SSL routines:ssl3_read_bytes:tlsv1 alert access denied:s3_pkt.c:1472:SSL alert number 49:
Oct 23 15:16:31 ns1 postfix/smtps/smtpd[52443]: lost connection after CONNECT from unknown[192.10.0.1]
Oct 23 15:16:31 ns1 postfix/smtps/smtpd[52443]: disconnect from unknown[192.10.0.1] commands=0/0