PostFix or sendmail, contact us magento module delivering

Hello to everyone,

Let’s start saying that i’m investigating the problem as newbie.
I setup a virtualmin vps unmanaged host with two domain. One is still not configure, the other hosts magento cart.
I moved from a shared hosting where everything was working. Magento is working perfectly, just i’m not receiving email from my customer through the contact us module. I get positive sent and all the emails end in var/spool/mail/root without reaching the real email box hosted on google apps (dns are still on the old hosting). In the log: is the domain, prs the main user for it. any ideas? both postfix and sendmail do the same…

Dec 5 16:27:36 prs sendmail[9808]: alias database /etc/aliases rebuilt by Diego Dec 5 16:27:36 prs sendmail[9808]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total Dec 5 16:27:36 prs postfix/postfix-script[9877]: starting the Postfix mail system Dec 5 16:27:36 prs postfix/master[9878]: daemon started -- version 2.6.6, configuration /etc/postfix Dec 5 16:27:45 prs sendmail[9910]: qB5DRjc2009910: from=prs, size=471, class=0, nrcpts=1, msgid=<>, relay=prs@localhost Dec 5 16:27:45 prs postfix/smtpd[9911]: connect from localhost.localdomain[] Dec 5 16:27:45 prs postfix/smtpd[9911]: 9A2DD1821DF0: client=localhost.localdomain[] Dec 5 16:27:45 prs postfix/cleanup[9914]: 9A2DD1821DF0: message-id=<> Dec 5 16:27:45 prs sendmail[9910]: qB5DRjc2009910: to==?utf-8?B?c3VwcG9ydA==?= , ctladdr=prs (505/505), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30471, relay=[] [], dsn=2.0.0, stat=Sent (Ok: queued as 9A2DD1821DF0) Dec 5 16:27:45 prs postfix/qmgr[9881]: 9A2DD1821DF0: from=, size=887, nrcpt=1 (queue active) Dec 5 16:27:45 prs postfix/smtpd[9911]: disconnect from localhost.localdomain[] Dec 5 16:27:45 prs postfix/local[9915]: 9A2DD1821DF0: to=, orig_to=, relay=local, delay=0.07, delays=0.06/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox) Dec 5 16:27:45 prs postfix/qmgr[9881]: 9A2DD1821DF0: removed


If you look at root’s email, does it include any sort of error message?

Or is it just delivering the email to root as if root were the intended recipient?

One thing you may want to watch out for is if “” exists as a Virtual Server on this new server of yours, and if it has DNS or Mail for Domain enabled, it could be trying to deliver the message locally.


Hello eric,

thank you for your reply. I did already checked that setup looking around on the forum.
In the log there was no error messages. I finally solved. The hostname was, for istance, and postfix was not delivering email, just leaving them in root folder. Then i setup the hostname as and finally it is working. Do you have explanation for that?


Ah, yeah, you always would want to have your server setup to use an FQDN such as host.example.tld.

Also, having the hostname match an existing Virtual Server can indeed cause problems in some cases.

It sounds like you that though, which is great!


Perfect Eric,
i have another question: messages are now being delivered successfully but they are classified as spam.
I have mx entries pointing to google mx for my domain The account receives email from the host vps where the domain using mta postfix. I read they go to spam because they have no authentication data. Is there a way to make them valid? Should i set a smtp server ( with postfix or sendmail? what are common errors with that? thanks.