Postfix not starting: Cannot assign requested address

fatal: bind xx.xx.162.134 port 25: Cannot assign requested address
fatal: daemon initialization failure
i have delete virtual server that used ip xx.xx.162.134 .
but still not working

A reboot should fix this.

already rebooted no fix

Hmm, from the error it is likely that there is still something in a config file which is linked to the ip and port. You could try and find the offending entry yourself or, since we both appear to be in India, and if you can trust a stranger compatriot enough to let him access your system remotely, I volunteer to have a quick look and try and locate the offending entry in the config files.

That is, unless someone else here has a better idea. @Uddhab_p let’s await feedback from the community and then you can take a call on this.

1 Like

hi Calport,
thanks for your help.
i have deleted this ip from master.cf and its fixed now

Thanks for the feedback. I am glad it worked out for you.

Stay home, stay safe.