Postfix Map Source Problem w/ Ubuntu Gutsy

Hi,

Don’t know if this is where to post a question about VM GPL. I’ve installed the module fine on Ubuntu Gutsy but when I do the configuration check, I get:

A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

I’ve searched and found fixes here but none of them work. There appears to be no comprehensive documentation of map sources in Postfix and how to configure them. And when I wget the .deb version, it won’t install because it doesn’t recognize the file format. Same for trying to install the .deb version within Webmin. So I’m stuck.

Any ideas would be appreciated! Thank you…

Tim

If it helps someone, I found the fix to the error:

http://bliki.rimuhosting.com/space/virtualmin+notes

"Either edit the /etc/postfix/main.cf file and add:

virtual_alias_maps = hash:/etc/postfix/virtual

Or if you have a command line phobia, you can go to the Webmin Postfix module, go to Server > Postfix Mail Server > Virtual Domains

On that page for the "Domain mapping lookup table" field, select the radio button, next to the blank field, and put this in there:

hash:/etc/postfix/virtual"

This worked in my situation.

Tim

Hi Tim,

thanks a lot, it works for me !

echo "virtual_alias_maps = hash:/etc/postfix/virtual" >> /etc/postfix/main.cf

Regards

– federico

Thanks Tim for providing the solution! So many people these days doesn’t take the time to submit to the solution that they posted… Again Thanks!

Hi tim, still helping, worked.