Postfix Mail Deferred [SOLVED]

I’m having major email headaches.

I’m running Virtualmin on Ubuntu Server with a few websites/domains, and email is working very inconsistently. Even wnd when it does get delivered, it is delayed significantly. The mail log gives me this frequent error:

Feb 4 19:53:50 host postfix/error[7367]: E079C7E14CB:,, relay=none, delay=1128, delays=1128/0.02/0/0, dsn=4.3.0, status=deferred (mail transport unavailable)

I also get this error less frequently:

Feb 4 20:03:50 host postfix/qmgr[32654]: warning: connect to transport private/amavis: No such file or directory

That last error makes no sense, because I can’t find any missing files related to Amavis. I’ve done a couple of days of Google searches, and this problem seems to be frequently tied to Dovecot and Amavis failures, but I’ve confirmed that both are running and listening on their ports, and they’re properly listed in

Could someone point me in the right direction?

Ubuntu Server version 18.04
Webmin version 1.900
Usermin version 1.751
Virtualmin version 6.05

Okay this is embarrassing, but I solved it… by rebooting the server.

Apparently restarting Postfix, Dovecot, and Amavis wasn’t enough. You just have to reboot the whole thing.