Postfix email header question

I am seeing values in my sent email headers that don’t look right so I thought I would ask here for help.

The original Received: from header for emails sent from phplist are like this:

Received: from (unknown [xx.xx.xx.50]) by (Postfix)

notice the unknown!

The original Received: from header for emails sent from other php apps that send via smtp are like this:

Received: from localhost (unknown [xx.xx.xx.50]) by (Postfix)

notice the unknown AND the localhost!

What can I do in my postfix settings to have the unknown be the correct value and how can I have the sending domain listed instead of localhost?

First – I believe the the field where it says "unknown" is a reverse lookup of your IP address.

If you type: host xx.xx.xx.50

Do you get a result? If not, you may need to talk to your ISP about setting up your reverse DNS (you control your DNS, but they control your reverse lookups).

As for your second question, that’s more difficult to resolve. Check out Joe’s response to this post:

Have a good one,

OK my rdns has been and is good in that:
host xx.xx.xx.50 domain name pointer

So it must be something else.

I looked at the link your provided and at the link in that link that joe provided and see something that might be the issue.

My VPS has an IP of xx.xx.xx.01
My virtual host on the VPS has a dedicated IP of xx.xx.xx.50

The Virtual host doesn’t use a mail server at xx.xx.xx.50 because it is using the VPS’s install of postfix so all mail is actually coming from xx.xx.xx.01

When I check host info like this:

host -t mx mail is handled by 5

host has address xx.xx.xx.50

Does the issue lie in the fact that has address xx.xx.xx.50 but mail is actually being sent from xx.xx.xx.01

Could this be why I am getting unknown in the header?

I wish edit worked but truthfully I would rather see Joe and Jamie working the software than on some forum install so I guess this is just a rant to ingore. Move along :slight_smile: