Postfix / Dovecot - SMTP Auth problem


I changed the login for usernames from the default user.domain to user@domain, receiving email is no problem, but when you send email the user@domain login doesn’t work, you need user@domain.tld@domain.tld and the users password to send email.

Is there something that can be changed to change user@domain.tld@domain.tld into user@domain.tld ?




I checked this topic:

Started to adjust mine settings a little, right now I have the following settings:

System Settings -> Server Templates -> Default Settings -> Mail for domain:

  • Format for usernames that include domain = user@domain

System Settings -> Module Config -> Defaults for new domains:

  • Include domain name in usernames? = Only to avoid a clash

Works perfect!