Postfix and SMTP authentication

I am using Ubuntu and I have installed Virtualmin GPL. In Outlook “My outgoing server requires authentication”, the SMTP authentication will only work with name-domain.com despite the fact that the IMAP server accepts name@domain.com as there is valid Unix users name@domain.com and name-domain.com. How can I make the SMTP server accept the Unix users name@domain.com?

PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"

Format for usernames that include domain, already used name@domain.com.

But still cannot work with SMTP authen “name@domain.com”, only can use “name-domain.com”.

And I found from the '?"
The username@domain option is not recommended unless you are migrating users from another system that already uses it. The Postfix mail server has problems with SMTP authentication by users with an @ in the username, and requires that an extra Unix user be created for each mailbox for mail delivery to work.

Since I migrate users from another system, how can I create extra Unix user?

The extra user should already exist, if you have selected the option. You can check /etc/passwd to be sure, though.

Don’t know how to do it. Could you help to explain more detail?

I mean just look in the file named /etc/passwd to be sure there are two users for each “user”.

You can use the Webmin->System->Users and Groups module to see them, as well, if you’re uncomfortable with the command line (I think…I don’t think it’ll hide them from you…in Virtualmin they get listed as a single user, even though there’s actually two).

But, what I was getting at was that this is not your problem. If you have the option enabled, and you created users after you enabled the option the users do exist. You don’t need to check. That’s not the problem you need to solve. If you created the users before making the switch, then you need to either remove them and recreate the or manually add the extra users, because that option configures the user creation behavior.

There were a few fixes to SMTP authentication configuration in virtualmin-config packages 6.0.16 and 6.0.18. You can make sure you have those fixes by running the following (after making sure your system is up to date):

# virtualmin config-system --include SASL # systemctl restart postfix