postfix and sendmail

I think I tried to get an answer a year ago and never did so I’ll try.
Has anyone ever gotten postfix and sendmail to play together on the same network? I’m currently up to date on VM on CentOS 4.5

I’d forgotten about it and so I thought I’d try postfix again and got sorely reminded. I have sendmail running on my nameservers and I tried to run postfix on another box and send mail and get nowhere with the message:

"15: Peer connect failure (the host has refused the connection)."

I find nothing in the messages, mail, or secure logs indicating any attempt to try to make a connection.

For what ever reason, Postfix seems to strip the box hostname from the root domain address thus trying to relay the mail through the root domain box which is running sendmail. But why, as the MTA, does it pass off the mail elsewhere in the first place. I don’t know that if it has a default setting to hand off the mail?

I don't know that if it has a default setting to hand off the mail?

Hehehe…Yes, it is the default setting, if it doesn’t know that your box is the mail exchange for the zone in question. i.e.: Either your DNS or your hostname or your virtual map table is broken, leading Postfix to think it needs to send the mail to someone else.

I suspect DNS.

All I want for Christmas is my SMTP, my SMTP, yes my SMTP (oops sorry, that’s two fwunt teef)

Hey Joe,

Ah, DNS is always so much fun and time consuming for trial and error.

After placing an MX address in the DNS master for the said host I still get " peer connection failure" with postfix and MD5 signature refusal with sendmail. Unfortunately the postfix error doesn’t get logged anywhere as a denial, on the host or the primary nameserver which is also the root domain host. Perhaps my DNS architecture is wrong though working for all other parts.

Essentially I have all the hostnames set up as host.rootdomain.tld masters on the primary nameserver with root domain also as a master on the primary. (none except the root domain had MX records but I’ve placed them since). Do I need to place the host.rootdomain.tld masters on the individual boxes and slave to the primary and secondary? When I tried that awhile ago I ran into the Chicken and egg routine trying to setup cluster servers.

I’m not sure of the virtmap table in postfix, but it’s pretty similar to the sendmail so I don’t see any glaring errors. Hostname settings were fixed to search host then DNS ( that was the problem in not getting cluster slaves working). Does postfix require reverse addressing? VM doesn’t create any reverse addresses so I’m not sure.

bottom line, Postfix, sendmail, I really don’t care which but I really need to get SMTP authentication working so I can open up these servers to the public.


PS: Did you get my last couple emails regarding bulk liscense and some security issues?

Now we’re getting somewhere-----nowhere I believe, but at least I have a log entry.

Caught the saslauthd dialog in the webmin mail list and added -r to the saslauthd config and, though I still get peer connection failure I at least have a log entry to follow.

Dec 17 00:00:02 a102 postfix/pickup[14053]: 2DE1F3E8036: uid=0 from=<root>
Dec 17 00:00:02 a102 postfix/cleanup[14058]: 2DE1F3E8036: message-id=<>
Dec 17 00:00:02 a102 postfix/qmgr[13933]: 2DE1F3E8036: from=<>, size=593, nrcpt=1 (queue active)
Dec 17 00:00:02 a102 postfix/smtp[14060]: warning: no MX host for has a valid address record
Dec 17 00:00:02 a102 postfix/smtp[14060]: 2DE1F3E8036: to=<>, orig_to=<root>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for type=A: Host not found)

WHy is postfix pre-pending the root domain name to the root domain name? It still won’t place the computer’s host name in it’s path. Sendmail isn’t encountering this situation, it just crashes on authentication. The DNS records are good, are they just misplaced

Postfix still has a peer connect problem so I changed back to Sendmail. I used putty to telnet in remotely and got this:

telnet 25
Connected to (
Escape character is ‘^]’.
220 ESMTP Sendmail 8.13.1/8.13.1; Thu, 20 Dec 2007 22:18:39 -0600
ehlo Hello [] (may be forged), pleased to meet you
250 HELP

Still don’t know what’s going on here and why my IP is claiming to possibly be forged