Possible Virtualmin bug in Debian Linux 11: 'Last email login' always shows 'No logins recorded yet'; is incorrect

SYSTEM INFORMATION
OS type and version Debian Linux 11
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

In Virtualmin → Edit Users, click a user and in Email settings, the label ‘Last email login’ always has the caption ‘No logins recorded yet’ even when the user accesses his mailbox via POP, IMAP or SMPT.

The bug is that Virtualmin on Debian is unable to detect that the user has accessed the mail account.

1 Like

Same thing with Ubuntu 22.04 and Virtualmin 7.10
last-email

How strange. On my Ubuntu 22.04 systems, this works but the dates look a bit off for a regularly accessed mailbox.

Last email login
SMTP (sending email) 04/20/2024 07:34 AM
IMAP (fetching email) 06/05/2024 01:46 AM

Is this a Pro feature? I am using GPL. I believe this has never worked on my personal installation and thought it to be a Pro feature.

I have always had this work on my Virtualmin GPL systems.

Only thing I can think of is a perl module missing on our servers for this to show the output.

It’s not a missing Perl module. It probably means you’re using a different log than that what Virtualmin expects for your OS and version. There has been a switch from mail.log to the journal on newer systems. If Virtualmin thinks it’s the wrong one, it’ll never see any logins.

So, to be clear, if you’ve installed rsyslogd and started logging to mail.log instead of the journal, and if Virtualmin thinks the journal is where you mail log is, then it will never find it.

It’s possible Virtualmin gets the default wrong on Debian 11 (I don’t actually know where it logs for mail, so it’s very possible Virtualmin doesn’t know either).

I’m using Ubuntu 22.04 with mail.log that was setup during Virtualmin install.

I don’t think Ubuntu 22.04 defaults to mail.log, I’m pretty sure it goes to the journal by default. Virtualmin doesn’t set that up. We install packages, and whatever the default is for those packages is how it stays unless you change it.

I have 36 installations that beg to differ…

I had time to check another account on this server that has email and it actually shows a login time but from few months ago.
last-loging-date

I’m wondering if somewhere in Virtualmin settings there is an option to turn this off? This is a server for personal use and the only installation of Virtualmin I have. Plus, I can’t find anywhere in my notes for March making any such changes to the server.

Add note: I found in my notes dated for March 24 2024 Virtualmin update.

SYSTEM INFORMATION
OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10:69
Package updates All installed packages are up to date

This is not in any way any sort of problem.
Curiosity caused me to look. With multiple active mail users in different domains on this VPS.
I keep a txt file of all updates by date for just in case.
update-3-24-24.txt - am about that time


    Installing package(s) with command apt-get -y install webmin-virtual-server ..

    The following packages will be upgraded:
      webmin-virtual-server
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 4149 kB of archives.
    After this operation, 2048 B of additional disk space will be used.
    Get:1 https://software.virtualmin.com/vm/7/gpl/apt virtualmin/main amd64 webmin-virtual-server all 7.10.0.gpl-1 [4149 kB]
    [master a0beb05] saving uncommitted changes in /etc prior to apt run
     1 file changed, 1 insertion(+), 1 deletion(-)
    Fetched 4149 kB in 3s (1297 kB/s)
    (Reading database ... 
    (Reading database ... 5%
 (Reading database ... 100%
    (Reading database ... 208047 files and directories currently installed.)
    Preparing to unpack .../webmin-virtual-server_7.10.0.gpl-1_all.deb ...
    Unpacking webmin-virtual-server (7.10.0.gpl-1) over (7.9.0.gpl-1) ...
    Setting up webmin-virtual-server (7.10.0.gpl-1) ...

    [master 7c2c3c7] committing changes in /etc made by "apt-get -y install webmin-virtual-server"
     5 files changed, 17 insertions(+), 9 deletions(-)
    NEEDRESTART-VER: 3.5
    NEEDRESTART-KCUR: 5.15.0-101-generic
    NEEDRESTART-KEXP: 5.15.0-101-generic
    NEEDRESTART-KSTA: 1

    .. install complete.

Last email login
IMAP (fetching email) 03/24/2024 08:04 AM
SMTP (sending email) 02/07/2024 12:18 PM

Last email login
IMAP (fetching email) 03/24/2024 07:52 AM

Last email login
IMAP (fetching email) 03/24/2024 08:19 AM
SMTP (sending email) 03/27/2023 09:00 PM

Last email login
IMAP (fetching email) 03/24/2024 08:19 AM
SMTP (sending email) 04/07/2023 09:43 PM

Last email login
IMAP (fetching email) 03/24/2024 08:19 AM
SMTP (sending email) 04/07/2023 09:39 PM

From what I remember reading here, a new install of Debian 12 uses the new. The provider I went with only offered Debian 10. (The only RH variant they had didn’t like the Rocky/Alma? upgrade script) So, I technically started with 10 and upgraded to 11 before my install. Even though I’m on 11, I don’t know what the default is, or, if @calport even started there.

Seems like a check that needs to be made?

There was a bug in Virtualmin 7.10.0 that didn’t display last login time correctly. It will be fixed in upcoming Virtualmin 7.20.0 though.

2 Likes

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.