Posftfix/Dovecot receive email... no way!

Hello, I am struggling 2 days to setup mail server with webmin/virtualmin.

I already can send mail but every incoming message bounces with error unknown user.

If anyone want to help please tell me what info you need.

Thank you in advance

postconf -n :

alias_database = hash:/etc/aliases alias_maps = hash:/etc/aliases append_dot_mydomain = no biff = no broken_sasl_auth_clients = yes canonical_maps = hash:/etc/postfix/canonical config_directory = /etc/postfix inet_interfaces = all mailbox_command = procmail -a "$EXTENSION" mailbox_size_limit = 0 mydestination = $mydomain myhostname = host.epetroupoli.gr mynetworks = 127.0.0.0/8 readme_directory = no recipient_delimiter = + smtp_tls_note_starttls_offer = yes smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination smtpd_sasl_auth_enable = yes smtpd_sasl_local_domain = smtpd_sasl_path = private/auth smtpd_sasl_security_options = noanonymous smtpd_sasl_type = dovecot smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem smtpd_tls_auth_only = no smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key smtpd_tls_loglevel = 1 smtpd_tls_received_header = yes smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtpd_tls_session_cache_timeout = 3600s smtpd_use_tls = yes tls_random_source = dev:/dev/urandom virtual_alias_maps = hash:/etc/postfix/virtual virtual_transport = dovecot

Howdy,

What does your “/etc/postfix/virtual” file look like? Do you see your domain names and email addresses mentioned in there?

-Eric

name@domain.com name/@domain.com

Do you see a line in there that reads something like “domain.com domain.com”?

Also, if you go into System Settings -> Re-Check Config, goes it detect any problems?

-Eric

There is no such line and recheck config passes all the tests.
I added a line like that in virtual and updated the db file with postmap but still nothing.