pop 3 Connection Refused.


I am getting a connection refused from my port 110. Any way to check whats going on ? Imap works fine but pop2 fails.


I tried doing a localhost telnet …

I get a connection Refused on port 110. I need a quick fix to this :frowning:


Hi Faisal,

Check your Dovecot configuration. By default, POP3 is enabled, but perhaps you disabled while making other changes. You can use the Webmin module or check the /etc/dovecot.conf file.

A good debugging technique is to restart the server while watching /var/log/messages. For example:

service dovecot restart; tail -f /var/log/messages

Will probably catch anything important on startup (you might instead have two terminals, one for the tail and one for the service restart–very chattery services like BIND could easily generate logs before the tail begins if done all on one line…but I don’t think Dovecot is generally that way).

You can also grep for dovecot relevant data:

grep dovecot /var/log/messages

If you aren’t sure what to make of what you see, send it on into the forum. Dovecot can also be configured to generate more logs, if you aren’t seeing any errors (but if you aren’t seeing errors the problem is more likely configuration, and we’ll want to see the dovecot.conf file).


Joe beat me to the punch, so I just have one thing to add. After following Joe’s advice for checking the Dovecot configuration, you may also want to check your firewall configuration (i.e. /etc/sysconfig/iptables) to make sure that port 110 is open.

BTW, here are the relevant lines in /etc/dovecot.conf:

Protocols we want to be serving:

imap imaps pop3 pop3s

protocols = imap pop3

Hey Guys thanx for the info :slight_smile: the problems was pretty straight forwards HEre is Jamie’s Response.



Awesome. I just couldnt figure out that i needed to Select it :slight_smile: now it works Good.

On Thu, 17 Nov 2005 8:23:00 1100, Jamie Cameron Jamie wrote:

Perhaps Dovecot is not configured to listen on the POP3 port? In the latest version of Webmin there is a dovecot module, and under its first icon you can select which protocols are in use. Most likely IMAP is selected, but POP3 is not.

- Jamie

I had checked both those things, I actually checked every possible scenario. Thr problem was just simple!! :slight_smile: