Please help with setting up DNS

A while ago I managed to install Virtualmin on my VPS following a tutorial online.

I have finished doing the following things:

  1. Installed Virtualmin
  2. Replaced Apache with Nginx
  3. Replaced MySQL with MariaDB
  4. Created a virtual server for my domain (

The problem is during setup the initial setup I kept the name servers as

I had no idea what the purpose of this was. I also tried adding the above mentioned nameservers to my GoDaddy domain, but they weren’t accepted.

Now when I open my site, it just opens op the home folder with the (leftover) apache page.

What do I have to do to get my domain to direct to the correct public_html folder (I have wordpress files there waiting to be installed).

Update 1

So I read up on some stuff online and disabled the BIND DNS server on Virtualmin
I was previously hosting my domain on RamNode’s DNS Host, didn’t really set up things well earlier so I thought I’d upgrade.

I managed to get the “Suggested DNS Records” for my virtual server in virtualmin IN A IN A IN A IN A IN A IN A IN A IN A IN A IN A IN MX 5 IN TXT “v=spf1 a mx ip4: ip6:2a00:d880:5:119::625e ?all”

I updated the values on my DNS Host, and waiting to see if it works.


Just to verify, is DNS being hosted on a third party, rather than on your server?

If so, you’re not likely seeing a DNS issue.

Are you perhaps using Debian or Ubuntu?

If so, you may want to remove the default website, which can be done with this command:

a2dissite 000-default

And then restart Apache.


I’ve run the command but I’m not using Apache anymore though.

I am using RamNode’s DNS Hosting, which is external, I don’t really know how to set it up to point to my VPS. My old setting worked but they redirected to the default apache page as I said earlier.

So what I did was I logged in to my DNS control panel and deleted all the records for the domain and replaced it with the ones mentioned in the virtual server, as in my first post.

Now, my website doesn’t respond. I’m really stuck I could use some one to walk me through to get it working again.
I also saved a copy of my previous DNS config just in case it didn’t work.

Wjen I open the IP of my server, all I get is an error 403 Forbidden nginx/1.10.0 (Ubuntu)