Please help me!

I can´t for my life fix following error:

----- The following addresses had permanent fatal errors -----
<info@reimers.se>
(reason: 553 5.1.8[webmin@kundserver.www1>… Domain of sender address webmin@kundserver.www1
does not exist)

The computername of my server are "kundserver.www1".

I’m a newbis, and lerning all the time, but rigt now i’m lost :wink:

Lars Reimers
info@reimers.se

Hey Lars,

So this domain wasn’t setup with Virtualmin–it is the actual hostname of the system?

I suspect the problem is that your system doesn’t know that its name is kundserver.www1. It probably thinks it is localhost.localdomain (or something else).

Postfix ships with a configuration that accepts mail for $myhostname (which should be kundserver.www1, but appears not to be) and localhost.$mydomain (which probably doesn’t apply to you). So, the solution can be to fix the hostname at the system level, or it can be to explicitly tell Postfix to accept mail for this name even if it thinks it isn’t the systems hostname. I generally prefer to fix the root of the problem–in this case the hostname of the system is not what you and DNS thinks it is.

First, you can see what the system thinks its name is using the hostname command:

# hostname

Likewise, you can see what postfix thinks the hostname is:

# postconf myhostname

If it is incorrect, you can correct it by editing /etc/sysconfig/network and changing the HOSTNAME parameter (or adding one if there isn’t one in the file):

HOSTNAME=kundserver.www1

And, to make it the hostname immediately, use the hostname command again:

# hostname kundserver.www1

Then restart postfix:

# service postfix restart

Now we can check to see what postfix thinks about the myhostname parameter:

# postconf myhostname

And if things still don’t work right, check to be sure the $mydestination variable hasn’t been changed from the default (I’ve included the output on my system, so you can see what the default ought to look like):

# postconf mydestination
mydestination = $myhostname, localhost.$mydomain, localhost

If it has been changed, you can fix it by browsing to Servers:Postfix:General Options, and set "What domains to receive mail for" back to Default. Save and apply your changes and test it.

This ought to at least get you started on a solution–if this doesn’t whip it right into shape, feel free to come back with more details (especially the output of the hostname and postconf commands above).

Dear Joe,

Thank you for the fast replay, I’ll tray your solution, and comming back with the result.

Thank you!

Regards,

No, sorry that don´thelps me!

Her are the result:
> hostname
kundserver.www1
> postconf mydestination
mydestination = $myhostname, localhost.$mydomain, localhost

That seems to be OK, if I mail to you my loggin to the server, maybe you will be nice to see if I have mess up somethings.

Regards,