phpMyAdmin requires PHP 5.2+

Hello everyone,

After the latest update of Virtualmin Pro at 3.64, phpmyadmin also updated to the latest version 3.1.0. The problem is that phpmyadmin now requires PHP 5.2+

I am using Centos 5.2 and PHP 5.1.6. When I try to run phpmyadmin it shows me this message: "phpMyAdmin - Error - You should upgrade to PHP 5.2 or later".

I think an update to PHP would be welcome. :smiley:

Edit: You are providing the updates to php, aren’t you?<br><br>Post edited by: m4b, at: 2008/12/20 01:18

for centos you’ll need to update yourself all though I read in the forum somewhere there is such version on the virtualmin servers.

I think you need to add some repo to your system to get it.

add the repo from http://www.jasonlitka.com/yum-repository/

actually you want to exclude a few items before you use it.

$ cat utterramblings.repo

[utterramblings]
name=Jason’s Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
exclude=apr* httpd*

There’s also the bleeding edge CentOS repo from virtualmin here, albeit unsupported.

http://www.virtualmin.com/component/option,com_openwiki/Itemid,48/id,virtualmin_bleeding_edge_packages/

for centos you’ll need to update yourself

Is this going to be something that is always the case with CentOS, in that I will have to upgrade it myself or will it be updated with a future virtualmin update?

As any distribution ages, the packages available on it aren’t going to be the latest and greatest. CentOS 5 is 3 years old now… the PHP 5.1.x packages that it has were pretty new back then.

Since some newer web apps do require a more up to date PHP version, Virtualmin offers a bleeding edge software repository for CentOS, where you can get PHP 5.2.x. You can read more about that here:

https://www.virtualmin.com/documentation/id,virtualmin_bleeding_edge_packages

I have seen talk here and there about keeping things updated for all kinds of reasons and security being one of those reasons. Do I have any cause for concern when it comes to security? So far I have not found the need that I need to upgrade as far as certain applications needing it. After reading the article on bleeding edge repositories, think I would only upgrade right now if security was a concern.

Being a complete noob to linux I’m wondering if it would be likely that CentOS would release an update through their repositories in the future?

CentOS 5 is 3 years old now… the PHP 5.1.x packages that it has were pretty new back then.

Being a complete noob to linux I’m wondering if it would be likely that CentOS would release an update through their repositories in the future, through yum update?

I remember reading somewhere that virtualmin was best run on centos and most hosting providers use centos too. Maybe that was an outdated document. I’m curios as to what would be the best, out of the box distro with the most current and up to date everything?