phpmyadmin issue

Hello, I just tried to install phpmyadmin and got met with the following issue

Failed to install script : This script cannot be installed, as this virtual server does not meet its requirements : phpMyAdmin requires PHP version 5.5 or later


What distro/version is it that you’re using there?

Also, what is the output of the command “php -v”?


…as the error said phpMyAdmin requires PHP version 5.5 or later - update your php or os… :slight_smile:

I am running Centos 7
The output of php -v is

[root@websrv ~]# php -v
PHP 5.4.16 (cli) (built: Apr 12 2018 19:02:01)
Copyright © 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies


It looks like you’re using PHP 5.4 there, the error you’re seeing indicates that you need a more recent PHP version.

Did you install Virtualmin recently? More recent Virtualmin versions automatically install PHP 7 alongside the distro’s PHP version.

You can try switching to that by going into Server Configuration -> PHP Versions.