PHP5 + GD2 missing imageantialias support.

Hi there,

Running debian 4 + virtualmin GPL and got everything setup - execpt when i got php scripts calling imageantialias function in GD2 it doesnt work.

I got GD and Imagemagic installed and setup and have added the appropriate files to the php.ini file.

It seems the standard php5 build you get on using apt-get just doesnt support the use of GD2 antialias on php - it does work for the CLI so its a bit strange.

Ive read somewhere the fix was to remove all php5 and build and installa it yourself on the box using enable gd command - but i am not sure thats a good way to go around it.

If i upgrade to virtualmin pro will this problem med solved? As far as i can see the only thing that differs in the GPL and pro version are the install script options so i am a bit in doubt if its worth upgrading.

If you’re sure it actually doesn’t work in CGI mode but does in CLI, then it’d be worth filing a ticket with the Debian folks if you need that functionality. But I suspect it’s just a misconfiguration.

We only provide PHP packages that are missing on a given platform–so we provide php4 packages on CentOS 5, for example. But we do not provide php 5 packages on Debian 4.0. So, Virtualmin Professional would have nothing to say about this problem.

Anyway, you haven’t mentioned what errors you’re getting or how you’ve enabled it in your php.ini, and exactly what packages you have installed. With that, I’d be able to try to reproduce your problem and suggest possible fixes (or tell you that it’s definitely something that the Debian developers need to fix).

Whenever i got a php script calling the imageantilias it wont work.

I.e.:

		$dst = imagecreatetruecolor($tn_width,$tn_height);
		imageantialias ($dst, true);
		imagecopyresampled ($dst, $src, 0, 0, 0, 0, $tn_width, $tn_height, $width, $height);
		imagejpeg($dst, $resized, 90); 

The imageantialias works fine int he CLI but it seems (also what i have read on the net) that the php5 module used by installing php5 by apt-get / virtualmin isnt the right one - you need a home built php with gd-enabled during the built to make it work correctly.

Its supposedly an old bug so quite annoying but was thinking maybe virtualmin pro had a solution for it - id rather not have services running i cant update via apt-get.

The debian folks should be using the gd-bundle like everyone else is using which does NOT have this bug. I have seen the same thing posted all over the place. Just google it. So debian does know about it and they simply do not care.