PHP Versions Error - mod_fcgid: error reading data from FastCGI server

Operating system:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.6 LTS
Release: 14.04
Codename: trusty

Webmin and Virtualmin Version

webmin version: 1.955
virtualmin version: 6.12


I am not able to run php7 or 5.6. I can only run version 5.5.9 of php. On the tab “Server Configuration > PHP Versions” i changed to PHP 7.0, but it doesn’t work.

I noticed that it is not created /home/user/etc/php7.0/php.ini. I created the folder, assigned the permissions and copied the file from “/etc/php/7.0/cli/php.ini”, but it still doesn’t work.

The following error appears in the log file

Connection reset by peer: [client X0.1X1.1X0.1X2:59980] mod_fcgid: error reading data from FastCGI server
[core:error] [pid 1251] [client X0.1X1.1X0.1X:59980] End of script output before headers: index.php

I have the following php versions installed

update-alternatives --list php
/usr/bin/php5
/usr/bin/php5.6
/usr/bin/php7.0

ll /etc/php
total 36
drwxr-xr-x   7 root root  4096 Oct 16  2018 ./
drwxr-xr-x 141 root root 12288 Dec 13 17:51 ../
drwxr-xr-x   5 root root  4096 May  2  2017 5.6/
drwxr-xr-x   6 root root  4096 May  2  2017 7.0/
drwxr-xr-x   3 root root  4096 May  2  2017 7.1/
drwxr-xr-x   3 root root  4096 Jun 15  2018 7.2/
drwxr-xr-x   3 root root  4096 Oct 16  2018 7.3/

php -v
PHP 5.5.9-1ubuntu4.29 (cli) (built: Apr 22 2019 18:33:52)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies

Can anyone help?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.