PHP script execution mode does not change

Hi,

I’ve got 4 domains under a server and after an upgrade 2 of them stopped loading the php.ini from user home and instead loading the /etc/php5/cgi/php.ini

The output from php info for server api is: “Server API CGI/FastCGI” which seems ok but under the “PHP script execution time” it shows mod_php and when I’m trying to change it to fastcgi is gives no errors but the value does not update and when I come back it still shows mod_php.

The server running latest Debian.

Any ideas?

Howdy,

What is the output of this command:

php -v

Also, if you go into System Settings -> Re-Check Config, does it detect any problems?

-Eric

Hi Eric,

Re-check configuration returns no problem at all.

$#php -v

PHP 5.4.4-14+deb7u9 (cli) (built: Apr 18 2014 14:34:31)
Copyright © 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2012 Zend Technologies

Anyone with a suggestion for this?

Thanks

Howdy,

Can you think of anything that’s unusual about these particular domains?

Are they using a non-standard DocumentRoot, perhaps?

I’ve occasionally seen some unusual things happen when the DocumentRoot is changed from the default.

-Eric