PHP-FPM Virtual server - Failed to save resource limits

OS type and version: Ubuntu 20.04
Webmin version: 1.981
Virtualmin version: 6.17-3 Pro


Hi i have another problem with Virtualmin on a virtual server ( main server is, where the virtualmin panel is accessed, and the virtual server for the domain …) . I have multiple PHP versions, PHP 7.4 , 8.0 and 8.1, and for the on the Services tab, PHP-FPM configuration,if i try to change the resource limits from it, i get an error message that says : " Failed to save resource limits : Don’t know which file to add to" and i cant edit it from here, i have to edit via ssh terminal. Any help how to solve this issue? The server uses ngnix.

Can you try changing PHP script execution mode on Server Configuration ⇾ PHP Options page?

It seems that if i change to cgi the resource configuration works , but when it is set to FPM it get me that error. But i also got an error when changed to cgi execution mode, on wordpress plugin updates, that was fixed when i changed back to fpm … Any workaround ?

I have to admit that i didnt try to switch the php from 8 to 7.4 and see if it works, but i have tried to change the execution mode on both the main server and the virtual server of the domain,and not working.

I have to admit that i didnt try to switch the php from 8 to 7.4

There are WordPress plugins that may fail with PHP 8. There is absolutely no reason for using PHP 8.0 in production. PHP 7.4 is perfectly fine!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.