php does't parse !


i am using virtualmin

my problem is php doest parse , ( shows insided php codes when open a php page in browser )

my /etc/httpd/conf/httpd.conf is

SuexecUserGroup “#503” “#503
ServerAlias www.
ServerAlias admin.
DocumentRoot /home//public_html
ErrorLog /var/log/virtualmin/
CustomLog /var/log/virtualmin/.5ps.org_access_log combined
ScriptAlias /cgi-bin/ /home/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory /home//public_html>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
AddHandler fcgid-script .php
AddHandler fcgid-script .php5
FCGIWrapper /home/
/fcgi-bin/php5.fcgi .php
FCGIWrapper /home//fcgi-bin/php5.fcgi .php5

<Directory /home/
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch

RewriteEngine on
RewriteCond %{HTTP_HOST}
RewriteRule ^(.
) https:// [R]
RewriteCond %{HTTP_HOST} =admin.
RewriteRule ^(.
) https://
** [R]
RemoveHandler .php
RemoveHandler .php5
php_admin_value engine on
IPCCommTimeout 31
FcgidMaxRequestLen 1073741824


If you go into System Settings -> Re-Check Config, does it discover any problems?

Also, what distro/version are you using?

And lastly, if you type this command, what output do you receive:

rpm -qa | grep php

System Settings -> Re-Check Config output is

"The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 7.75 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Your Postfix version does not support per-domain outgoing IP addresses.

Apache is installed.

The following PHP versions are available : 5.4.21 (/usr/bin/php-cgi)

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

IPv6 addresses are available, using interface eth0.

Default IPv4 address for virtual servers is

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

Default IP address is set to, which matches the detected external address.

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… your system is ready for use by Virtualmin."

my server distro is CentOS release 6.4 (Final)

while type this command rpm -qa | grep php

i get


please help me … as soon as…

my head is in trouble …

I think it’s problem with remi repo…
how do you think…?

can any one please make a comment to solve this issue…

my two server got in sick with this error…
in both repo is remi… that’s why I am scolding remi…
might be its compatibility issue


There’s info about the problem you’re seeing in the section of the following document titled “Why does PHP / ProFTPd no longer work after performing updates? (I’m using CentOS, and enabled third party repositories)”: