PHP broken after yum update

Hi all.
I have recently done a yum update on my Centos 5 based server.

After the update 2 Things were broken that i know of.

  1. Dynamic DNS updates did not work as named complained about access rights to .host.jnl files.

That was quick to fix.

  1. PHP is not working through httpd anymore.

A usual phpinfo() file gets executed properly via commandline.
A browser connection just waits…
A http file however works fine.

I have reinstalled both httpd and PHP

I have tried installing php4 or 5 and both.

the usual /etc/httpd/conf/conf.d/php.conf gets loaded correctly.

httpd -M confirms that php5_module (shared) is loaded etc.

It seems that apache and php is no longer interested in talking.

Nothing is logged to error.log in /var/log/httpd/error or in the corresponding /home/xxx/log/error.log

I’m stumped.

Any ideas?<br><br>Post edited by: dibatech, at: 2008/08/03 09:46

Yeah, that’s fairly odd.

First, what was the problem with the Dynamic DNS updates – was it a permissions issue?

Just a few thoughts though –

Just so we understand your setup, are you saying you have Virtualmin configured to use mod_php, rather than CGI or mod_fcgid (System Settings -> Server Templates -> Default Settings -> Apache Website -> Default PHP execution mode)?

And just in case, I suppose I’m curious how the permissions look on your PHP session directory:

ls -l /var/lib/php
-Eric

/var/lib/php

[root@ns1 ~]# ls -l /var/lib/php
total 20
drwxrwx— 2 root apache 16384 Aug 4 16:39 session

Thanx

You can check if mod_php or fastCGI is being used to run PHP scripts for the domain by selecting it from the left menu, opening the Server Configuration category, clicking on Website Options and looking at the ‘PHP script execution mode’ field.

Are you using the GPL or pro version of Virtualmin? The GPL release can only run PHP via mod_php, so has no option to change to a different mode.

Also, make sure you are logged in as root - other users may not have access to that Website Options page.

GPL.
Logging in as root.

Thanks for your help. really appreciated.
Is there anywhere i should manually add this in a file??

So it looks like mod_php is broken in some odd way…

Make sure that you have only one of PHP 4 or 5 loaded as an Apache module at any one time - having both can cause strange crashes.

  1. Yep. The dynamic DNS was a permissions issue.

  2. Virtual server template details (Apache website)

ServerName ${DOM}
ServerAlias www.${DOM}
DocumentRoot ${HOME}/public_html
ErrorLog ${HOME}/logs/error_log
CustomLog ${HOME}/logs/access_log combined
ScriptAlias /cgi-bin/ ${HOME}/cgi-bin/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory ${HOME}/public_html>
Options Indexes IncludesNOEXEC FollowSymLinks
allow from all
AllowOverride All
</Directory>
<Directory ${HOME}/cgi-bin>
allow from all
</Directory>

No mention of mod php, cgi or anything…

Does not seem to be there?

Create Virtual Server
Edit Virtual Server
Edit Mail and FTP Users
Edit Mail Aliases
Edit Databases

Does not seem to be there?

Create Virtual Server
Edit Virtual Server
Edit Mail and FTP Users
Edit Mail Aliases
Edit Databases