PHP 4 - just can't get it to work

Hi,
maybe I am stupid, but I just cannot get PHP4 to co-exist with PHP5 the way it is supposed too (apparently?). I hope someone there can give me an EASY solution for this.
I am running CentOS 5 with PHP 5. I have over fifty domains that all work perfectly. However, I have just ONE legacy server in our offices that I can’t move to virtualmin as it MUST have php4 to run.
I have contacted Joe and he advised me to do a yum install of php4 - which I have done.
However, once I restart (or try to) httpd - it fails with errors:
/bin/bash: line 1: 7555 Segmentation fault /usr/sbin/httpd

He also mentioned that I should do a recheck config and virtualmin shows the php options - which did not happen (no doubt due to httpd not restarting :frowning: )
Can someone please help?